CGTalk > Software > Autodesk 3ds max
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 10-26-2012, 08:42 PM   #1
Bryan3DBulldog
Veteran
portfolio
Bryan
3D Bulldog
Austin , USA
 
Join Date: Jul 2012
Posts: 43
Exclamation Viewport issues

My issue is with the models in viewport being distorted/transparent/invisible as well as edge facing not working when I go to any view other than perspective. I posted some pics of the problem.

Perspective - everything works as expected and looks fine.



Switch to top view and the problems begin. Models are distorted and flicker in and out. Edge faces will not work as well as you can not go to sub object modes such as vert or polygon and you can not select faces ect. I can however render the top view and it comes out fine.



This is a render and as you can see it comes out fine.





Things I have done:
1. Tested the scene on 2 different computers with different video drivers and graphic cards
2. Updated drivers for graphic card
3. applied standard textures
4. switched between nitrous and and hardware rendering
5. Contacted Autodesk and got a service ticket number


What I am using:
Autodesk 3DS Max 2013 64bit
EVGA GTX 285
NVIDIA Drivers 306.97-desktop-win8-win7-winvista-64bit-english-whql
Windows 7 64bit
 
Old 10-26-2012, 08:44 PM   #2
Bryan3DBulldog
Veteran
portfolio
Bryan
3D Bulldog
Austin , USA
 
Join Date: Jul 2012
Posts: 43
Forgot to add that I also reinstalled Max and i tested other models and they showed no problems.
 
Old 10-26-2012, 09:55 PM   #3
Bryan3DBulldog
Veteran
portfolio
Bryan
3D Bulldog
Austin , USA
 
Join Date: Jul 2012
Posts: 43
Okay I noticed for some reason now i can select verts and faces. But the problem of the models being see through and disappearing in all views other than perspective still remains.
 
Old 10-27-2012, 12:29 AM   #4
Diffus3d
Mad Scientist
 
Diffus3d's Avatar
portfolio
Alfred (AJ) DeFlaminis
3ds Max Tech Support
Autodesk
USA
 
Join Date: Apr 2006
Posts: 1,300
Does it flicker when you rotate in those viewports? Triangulate? (Meaning, only show half of polygons...)

This is odd, sounds to me like behaviour I've seen when my graphics card is overheating, but at the same time a bit different.

Fancy drivers?
 
Old 10-27-2012, 01:36 AM   #5
Bryan3DBulldog
Veteran
portfolio
Bryan
3D Bulldog
Austin , USA
 
Join Date: Jul 2012
Posts: 43
Quote:
Originally Posted by x24BitVoxel
Does it flicker when you rotate in those viewports? Triangulate? (Meaning, only show half of polygons...)

This is odd, sounds to me like behaviour I've seen when my graphics card is overheating, but at the same time a bit different.

Fancy drivers?


Yes when you rotate the top view causing it to go orthographic you get flickering ect. It is similar to a graphics card overheating (I have seen it happen in games) but its not overheating I am sure of that, plus i tested on 2 different computers.

its strange, the behaivor is a cross between a card overheating, the normals being backwards and the polygons disappearing (flickering). Strange thing is I am seeing it in another scene i am working on.

The only thing that comes to mind is that my scenes that are having issues are very heavy in geometry and that the issue only happens in views other than perspective.
 
Old 10-27-2012, 01:46 AM   #6
Diffus3d
Mad Scientist
 
Diffus3d's Avatar
portfolio
Alfred (AJ) DeFlaminis
3ds Max Tech Support
Autodesk
USA
 
Join Date: Apr 2006
Posts: 1,300
I wonder... is adaptive degradation on? (That little 3D cube thing near the timeline at the bottom.)

Might be that?
 
Old 10-27-2012, 02:11 AM   #7
Bryan3DBulldog
Veteran
portfolio
Bryan
3D Bulldog
Austin , USA
 
Join Date: Jul 2012
Posts: 43
I turned off viewport clipping and that fixed it. Thanks for the help.
 
Old 10-29-2012, 01:03 PM   #8
robinb
Expert
 
Join Date: Jul 2003
Posts: 2,915
This sort of thing is usually because the viewport clipping is set wrong. If you push the far plane out to the maximum range AND bring the near plane into the minimum you're stretching Z precision too far and you end up with essentially stripes of visible geometry. If you need the near plane brought in closer you should bring the far plane IN too to maximise the range. And vice versa. If you need a huge draw distance for an enormous model, push the near plane out further.

The idea really is to have the least possible distance between the two markers as the fixed precision is spread between them.
 
Old 10-29-2012, 01:09 PM   #9
robinb
Expert
 
Join Date: Jul 2003
Posts: 2,915
I should also have said that it makes no sense to enable viewport clipping in an orthographic viewport like the TOP one anyway. It's only really needed for perspective views.
 
Old 10-29-2012, 01:09 PM   #10
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 02:31 PM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.