CGTalk > Software > Autodesk 3ds max
Login register
Thread Closed share thread « Previous Thread | Next Thread »
 
Thread Tools Search this Thread Display Modes
Old 10-24-2012, 05:33 PM   #1
shapemaster
Frequenter
portfolio
Tao
CCA
San Francisco, USA
 
Join Date: Sep 2006
Posts: 294
bump maps going crazy

Hey guys,

I'm having some problems with bump maps in 3ds Max 2013 Design. I was wondering if anyone else has encountered the same problem and (more importantly) has found any solution to said problem.

Basically, whenever I apply a bump map to a material and render it, it gives me this extremely noisy texture, regardless of the file and intensity of the bump map. I tried adjusting the material settings, render settings, nothing works. It happens to every material. Without bump map it's fine.
I'm attaching a few screenshots to illustrate the problem.
First picture shows the noise in the rendering, second picture shows how the bump map is supposed to look like and last picture shows the file I used for the bump map.


Thanks!
Attached Images
File Type: jpg scnshot01.jpg (75.9 KB, 43 views)
File Type: jpg scnshot02.jpg (83.3 KB, 28 views)
File Type: jpg scnshot03.jpg (65.8 KB, 16 views)
__________________
Sketchbook
 
Old 10-24-2012, 05:50 PM   #2
CHRiTTeR
On the run!
 
CHRiTTeR's Avatar
Chris
Graphic designer extraordinaire
Belgium
 
Join Date: Feb 2002
Posts: 4,500
Can you post the same render but with bump maps disabled?
I ask this because it looks like it could be actually your lights not having enough samples?
Edges also seem verry jagged, which suggest you also arent using enough AA samples

Also, how much blur are you using for the bitmap texture?
I have had trouble before with setting this too low for bump maps...
 
Old 10-24-2012, 05:52 PM   #3
l3ftnut
Veteran
 
l3ftnut's Avatar
portfolio
G
RVK, Gambia
 
Join Date: Jun 2009
Posts: 52
I'm probably wrong but at first it seemed like it was turned way too high.

I guess it could be gamma related as well, I often get very random results when I haven't gamma corrected input textures. What gamma settings are you using? Both in the 3dsm gamma/lut tab and in the "select bitmap image file" browsing window.

Hopefully someone with more knowledge than me can help you in case it's not gamma related.
 
Old 10-24-2012, 06:28 PM   #4
shapemaster
Frequenter
portfolio
Tao
CCA
San Francisco, USA
 
Join Date: Sep 2006
Posts: 294
hey thanks for the speedy replies! I attached an image, showing the render with and without bump map. I just noticed this weird circular pattern that was obscured by the bump map. Maybe that is the source of the noise?


Where do you find the parameter for light samples?
Blur is set to 1.0
AA means Anti-aliasing I presume? It's set at 1/4 Minimum and 1 Maximum.

l3ftnut - where do I find the Gamma settings?

I'm pretty new to textures and rendering, so please excuse me while I try to figure where to find the settings!
Attached Images
File Type: jpg scnshot04.jpg (91.0 KB, 40 views)
__________________
Sketchbook
 
Old 10-24-2012, 06:40 PM   #5
CHRiTTeR
On the run!
 
CHRiTTeR's Avatar
Chris
Graphic designer extraordinaire
Belgium
 
Join Date: Feb 2002
Posts: 4,500
You have some heavy moiré going on there (the circular pattern you are talking about). Cant really see where that could be comming from... Are you sure you dont have any overlapping faces etc?

Yes, AA means anti alliasing. 1 max is quite low. Try setting it higher.
But even so, this pattern cerainly isnt 'normal'.

Maybe playing with your light's shadow bias can help. That also can help sometimes with weird shadow artifacts.


Im pretty sure it has nothing to do with gamma though.
 
Old 10-24-2012, 07:04 PM   #6
l3ftnut
Veteran
 
l3ftnut's Avatar
portfolio
G
RVK, Gambia
 
Join Date: Jun 2009
Posts: 52
Chritter is probably right about gamma not being the cause of this. However to answer your question. Go to Rendering-> "Gamma/LUT Setup" and then check the Enable checkbox.


What renderer are you using? Could you post image of your renderer tab in the "Rendering setup" window as well as your indirect illumination tab if you're using MR?

I tried applying your bump map to objects without any problems. Have you tried using it in a new scene or a new material?
 
Old 10-24-2012, 07:37 PM   #7
shapemaster
Frequenter
portfolio
Tao
CCA
San Francisco, USA
 
Join Date: Sep 2006
Posts: 294
Gamma/LUT correction is enabled.

I'm using mental ray.
Here are my renderer tab and indirectI tab:




I haven't tried it on a different scene yet, I will do that when I find some time later today.



CHRiTTeR - I'm pretty sure the geometry is clean. I may be new to rendering, but I'm pretty confident in my modeling skills. Unless, of course, something went wrong during the import/export process. I modeled the scene in Rhino 4, converted it into a mesh and then imported into 3ds max.

where can I find the shadow bias setting?
__________________
Sketchbook
 
Old 10-24-2012, 07:57 PM   #8
CHRiTTeR
On the run!
 
CHRiTTeR's Avatar
Chris
Graphic designer extraordinaire
Belgium
 
Join Date: Feb 2002
Posts: 4,500
Quote:
Originally Posted by shapemaster
I may be new to rendering, but I'm pretty confident in my modeling skills. Unless, of course, something went wrong during the import/export process. I modeled the scene in Rhino 4, converted it into a mesh and then imported into 3ds max.

where can I find the shadow bias setting?



Well thats exactly the kind of thing that messes up meshes like that (overlapping poly's etc).
I used to get that allot with imported meshes. It wouldnt hurt to check, just to be sure.

Shadow bias settings are found in the light's settings. Where exactly depends on what lights you are using.
 
Old 10-24-2012, 08:01 PM   #9
shapemaster
Frequenter
portfolio
Tao
CCA
San Francisco, USA
 
Join Date: Sep 2006
Posts: 294
Alright, I found some time to do a test with a new scene. I used the same day lighting setup on a generic box and it turns out to be just fine. That leads me think that maybe the material of the huge curtain wall window in the background causes the moire, as the light passes through the glass first before it hits the foreground? I don't know enough about rendering to verify that, so I'm just throwing it out there...

__________________
Sketchbook
 
Old 10-24-2012, 08:24 PM   #10
CHRiTTeR
On the run!
 
CHRiTTeR's Avatar
Chris
Graphic designer extraordinaire
Belgium
 
Join Date: Feb 2002
Posts: 4,500
Quote:
Originally Posted by shapemaster
Alright, I found some time to do a test with a new scene. I used the same day lighting setup on a generic box and it turns out to be just fine. That leads me think that maybe the material of the huge curtain wall window in the background causes the moire, as the light passes through the glass first before it hits the foreground? I don't know enough about rendering to verify that, so I'm just throwing it out there...




Could be, makes perfect sense...
Its hard to check stuff like that without the scene.
 
Old 10-25-2012, 08:03 PM   #11
shapemaster
Frequenter
portfolio
Tao
CCA
San Francisco, USA
 
Join Date: Sep 2006
Posts: 294
I tried to render the scene without glass, so the light would hit the surface directly. The moire pattern is still present, if not even more distinct.
I tried playing around with the shadow softness by changing its factor and sample rate, didn't work either.

Here's a render sample without glass:

__________________
Sketchbook
 
Old 10-25-2012, 08:13 PM   #12
pokoy
dental floss tycoon
 
pokoy's Avatar
portfolio
Marcin Gruszczyk
Germany
 
Join Date: Aug 2003
Posts: 2,355
Shouldn't AA samples be somewhere at 1 and 4 or 8 rather than 1/4 and 1? Not a mray user here but it just looks too low. The other example looks fine though.
 
Old 10-26-2012, 03:18 AM   #13
darthviper107
Expert
 
darthviper107's Avatar
portfolio
Zachary Brackin
3D Artist
Precocity LLC
Dallas, USA
 
Join Date: Feb 2004
Posts: 4,124
I usually use 1/16 for the sampling settings/

I would also turn speckle reduction down, in my experience turning it up makes things look worse.

Also check your material setting, there's a sample setting for your reflections there, I'd set it at 16 or 32
__________________
The Z-Axis
 
Old 10-26-2012, 03:01 PM   #14
pokoy
dental floss tycoon
 
pokoy's Avatar
portfolio
Marcin Gruszczyk
Germany
 
Join Date: Aug 2003
Posts: 2,355
Quote:
Originally Posted by darthviper107
I usually use 1/16 for the sampling settings/


To OP: I feel like this needs to be explained, it's 1 for minimum and 16 for maximum, not 1/16 for minimum samples, this would be way too few samples.

I think what you're seeing is bad antialiasing (or the lack of), that's why it worked fine on a fresh scene, it just had better antialiasing sampling settings by default. It's always recommended to have the first (min) sample at 1 and the second (max) one at 4,8 or 16, depending on how good you want the sampling to be.
 
Old 10-28-2012, 02:09 AM   #15
shapemaster
Frequenter
portfolio
Tao
CCA
San Francisco, USA
 
Join Date: Sep 2006
Posts: 294
Hey thanks for the input.

It seems that a reflection map with real-world-scale turned off caused the biggest problems. Deleting the map got rid of the moire pattern, but I will try out your suggestions, maybe it will eliminate all the noise.
__________________
Sketchbook
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:42 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.