how do i export my fully skinned character from maya 2014 to maya 2010?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
  08 August 2014
how do i export my fully skinned character from maya 2014 to maya 2010?

any plugins or technique would be appreciated.

Thank You!
 
  09 September 2014
I guess it's a little bit late for this but, in case you still need help, did you already try the Maya acii technique?
Basicly what you have to do is:
1- save your Maya 2014 scene as a Maya ascii (.ma) instead of Maya binary.
2- open the file using a text editor such as notepad.
3- in the text editor, at the very beginning, change the version number from 2014 to 2010 and save the file.
4- try to open it in Maya 2010 and do some testing.
Keep in mind that this could not work properly due to some node incompatibility. For an example, the skinCluster node has been updated since Maya 2010 so I'm not sure it's going to work at all...
 
  09 September 2014
Howdy,

Also, you could export with FBX and choose an earlier version. If it doesn't go back quite that far, there is the free FBX Converter application.

Adios,
Cactus Dan
__________________
It doesn't matter what people say about you, just as long as they're talking about you.

cactus3d.com, cactus3d-Plugins, CD Character Plugins forum
 
  09 September 2014
Originally Posted by jacopoS: I guess it's a little bit late for this but, in case you still need help, did you already try the Maya acii technique?
Basicly what you have to do is:
1- save your Maya 2014 scene as a Maya ascii (.ma) instead of Maya binary.
2- open the file using a text editor such as notepad.
3- in the text editor, at the very beginning, change the version number from 2014 to 2010 and save the file.
4- try to open it in Maya 2010 and do some testing.
Keep in mind that this could not work properly due to some node incompatibility. For an example, the skinCluster node has been updated since Maya 2010 so I'm not sure it's going to work at all...


You'll also need to remove a new construction history flag added to shape nodes. It's "-ch" and a number following it. You can remove it via a regular expression such as "-ch [0-9]* ", just replace it with nothing.

If you don't remove the flag, most if not all of your geometry will not be imported into 2010.

Also, when you save your file in 2014, under the options for save scene as, theres a checkbox called "Use full names for attributes on nodes". A lot of the short names were changed, so that should reduce the errors.

That or export as FBX like Dan mentioned.
__________________
ollarin.com
 
  11 November 2015
even its late, thanks folks i got it
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:23 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.