R20 expectations?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

REPLY TO THREAD
 
Thread Tools Search this Thread Display Modes
  1 Week Ago
here you go. I made this with R19 so the bug still exists. (I am quite shure, that I reported it to maxon many years ago)

https://we.tl/E5QRgxK4QZ

to demonstrate the uneven distribution I converted the spline and linked clones to the spline points.

I know of people that were aware of that bug too. And they also work around it.

Last edited by Jops : 1 Week Ago at 09:59 AM.
 
  1 Week Ago
Originally Posted by Jops: on regular splines the even spline distribution does not distribute the points evenly. there for cameras or pther objects that are animated on them via tag tend to jerk.
the mospline is not affected by this problem. most probably, because it is much younger.

I din't check it for a while, but the R17 I have here on my laptop still suffers from it.
When you make a spline and turn on uniform, and make sure the animation interpolation is not set to spline but linear there should be no issues of interpolation. If you make a duplicate of the test and use current state to object for the spline your see both animate at the same pace. If you then run on adaptive for the spline then you get your issue.

https://www.dropbox.com/s/pys1zvmho...0speed.c4d?dl=0

Dan
__________________
C4D R19 Studio, MODO 902, Zbrush 2018, Unfold3D 9,Marvelous Designer 7, Keyshot 6 pro.
 
  1 Week Ago
Ok, so with that, it only happens when there is a spline control handle where one side is set to zero and the other side is sticking out quite far to make a soft curve. In this scene your tangent lengths are 800 vs 0. This imbalance screws it up. If you can make your splines with more equally weighted handles then the problem goes away. Also, if the plan is to use mograph to add objects, then don't use the even mode in the first place, just set the mograph distribution to even and this works on all splines.

Essentially the only place left that this should cause a problem would be align to spline animations. But as you say, if you use mospline to rebuild the spline then this doesn't have the problem.
__________________
Matthew O'Neill
www.3dfluff.com
 
  1 Week Ago
if you use champfer it makes the splines like this.

I experienced this bug not just in this situation, but it is hard to exactly find out where the problem is.

I have several easy workarounds so I don't care to much. But anyway Splines are important and they are broken for ages.

Jops
 
  1 Week Ago
Originally Posted by Jops: here you go. I made this with R19 so the bug still exists. (I am quite shure, that I reported it to maxon many years ago)

https://we.tl/E5QRgxK4QZ

to demonstrate the uneven distribution I converted the spline and linked clones to the spline points.

I know of people that were aware of that bug too. And they also work around it.
Interesting! havent encountered this (or never noticed) before.
Uniform interpolation always seemed to work for me. Will keep my eye out for this.
If we are talking bugs now, I have a few I hope get ironed out as well and will post later.

Last edited by JoelDubin : 1 Week Ago at 02:42 PM.
 
  1 Week Ago
Originally Posted by Rectro: When you make a spline and turn on uniform, and make sure the animation interpolation is not set to spline but linear there should be no issues of interpolation. If you make a duplicate of the test and use current state to object for the spline your see both animate at the same pace. If you then run on adaptive for the spline then you get your issue.

https://www.dropbox.com/s/pys1zvmho...0speed.c4d?dl=0

Dan
Hi Dan,

Thanks for your reply.
I am not using the english version, so I translated uniform with even. My bad. But what You describe is exactly what I did.
And this is where the bug gets visible. If you look in my scene file you will see.
The bug is not so obvious so you might not have recognized it.

best regards
Jops
 
  1 Week Ago
Forget about some more must have features could be nice to have - round edge shader capable for baking and more parameters exposed for making scripts.
And thanks all for your comments on this thread. Hope it'll be a bit helpful some day for Maxon.
 
  1 Week Ago
Originally Posted by Rectro: When you make a spline and turn on uniform, and make sure the animation interpolation is not set to spline but linear there should be no issues of interpolation. If you make a duplicate of the test and use current state to object for the spline your see both animate at the same pace. If you then run on adaptive for the spline then you get your issue.


Dan

Yes. Maybe I'm missing something w/Jops posts, but I don't really see a bug with this; rather a logical extension of how points are arrayed on a spline and how the cloner --or other operations-- map to the spline's point array. Anyway...that's my opinion.
__________________
C4D R19 Studio, MODO 902, VRAY, Octane, Cycles. PC/Mac.

Last edited by IceCaveMan : 1 Week Ago at 03:20 AM.
 
  5 Days Ago
BUG fix requests for 20:

1. Multipass outputs an extra rgb pass whether its ticked or not. Anyone else have this issue?
Ive reported it before but havent gotten any feedback from Maxon TS.

2. there is an ongoing Team render client/server issue thats been present since TR started.
if you've got more than 20 clients running, TRS will crash. I assume this will probably never be fixed at this point, but one can always hope.

Requests for 20 and beyond:

Better SSS! Implemented like most other render engines, with multiple layers of input. And faster! SSS currently is very RAM memory intensive. I dont see my memory usage increase so much when I use SSS in Arnold or vray.

Fast Scattering like Arnold Octane and RS.

Curvature shaders.

Faster Physical render.
 
  4 Days Ago
Originally Posted by JoelDubin: BUG fix requests for 20:

1. Multipass outputs an extra rgb pass whether its ticked or not. Anyone else have this issue?
Ive reported it before but havent gotten any feedback from Maxon TS.

2. there is an ongoing Team render client/server issue thats been present since TR started.
if you've got more than 20 clients running, TRS will crash. I assume this will probably never be fixed at this point, but one can always hope.

Requests for 20 and beyond:

Better SSS! Implemented like most other render engines, with multiple layers of input. And faster! SSS currently is very RAM memory intensive. I dont see my memory usage increase so much when I use SSS in Arnold or vray.

Fast Scattering like Arnold Octane and RS.

Curvature shaders.

Faster Physical render.
Would be nice if they got Alsurface , and ALHair into Pro renderer along with making pro render faster and reliable all round with nodes of course, this would make me take notice of it. If they could get pro renderer to compete with Arnold and Vray then that would give me reason to invest into a new GFX card. I agree, SSS in C4D native is lacking, and certainly not even close to any dedicated skin material in these two apps mentioned.

Dan
__________________
C4D R19 Studio, MODO 902, Zbrush 2018, Unfold3D 9,Marvelous Designer 7, Keyshot 6 pro.
 
  4 Days Ago
Originally Posted by JoelDubin: BUG fix requests for 20:

1. Multipass outputs an extra rgb pass whether its ticked or not. Anyone else have this issue?
Ive reported it before but havent gotten any feedback from Maxon TS.
i think we're all experiencing that, quite annoying. i hope they are going to fix that madness. not sure why they didn't fix it already with the latest service update. seems like a rather simple thing to do.
__________________
________________________________
my stuff on vimeo
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:06 AM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.