Car rigging and moving issues

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
  3 Weeks Ago
Car rigging and moving issues

HI new to this forum long time c4d user

This is my first real venture into rigging full car
I Have a basic utility truck with suspension and at the moment no motor. I got everything set up fine all the suspension is leveled like i want but as soon as it hits the floor with a little bounce the car moves on its own either forward or backwards with the amount of friction on the floor. The less friction the more it goes backwards more it goes forwards, and this is with no motor in it. If i take the dynamictag off the wheels and body it stops dead
This is perplexing i cannot get it to even slow down nothing i do to it makes it stop moving
Does anyone know maybe whats wrong thank you

im using r18
 
  3 Weeks Ago
Here's a car made from primitives - has steering, gears. Yours should have similar hierarchy and suspension etc located the same. The friction is set high (or wheels spin), the steering wheels have some xpresso to make them straight ahead at F0 (else get wobbles), there's a low custom center of gravity (stops flipping when cornering fast) and the velocity threshold is set to zero (so stays dynamic after stopping).

https://www.dropbox.com/s/ju5tj8o1ycjtu3r/car.zip?dl=1
 
  2 Weeks Ago
Thank you for solving this issue I found out a few things my model didnt have all 4 tires on the ground and two thevelocity threshold was on default and so i turned it to zero and it finally fixed the issue of it rolling. So now its working as it should again thank you..
 
  2 Weeks Ago
Velocity threshold comes into play where the car has been stationary for > 2 secs (eg traffic lights). If you keyframe the motors to drive, stop for 5 secs, then restart, the car won't move the 2nd time because when the velocities have been < 10 units for > 2 secs it ceases to be dynamic ie won't restart. The trick to fix this is to set the thresholds to 0. A collision will however turn dynamics back on.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:57 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.