CGTalk > Software > Maxon Cinema 4D
Login register
Thread Closed share thread « Previous Thread | Next Thread »
 
Thread Tools Search this Thread Display Modes
Old 11-14-2013, 09:21 PM   #16
jimzepellin
Lord of the posts
 
jimzepellin's Avatar
James Leaburn
Bridge Officer
Dundee, United Kingdom
 
Join Date: Apr 2003
Posts: 626
Thanks Rick. Problem sorted. I knew someones spanner had fallen out of their pocket and gummed up the works.
__________________
If in doubt scream and shout.

C4D XL, ZBrush, Motion Builder
 
Old 11-14-2013, 09:48 PM   #17
Horganovski
Freelance Animator/Rigger
 
Horganovski's Avatar
portfolio
Brian Horgan
Graphite9
Dublin, Ireland
 
Join Date: Apr 2007
Posts: 4,852
One more slightly OT question for Rick -

I remember when I had the Cineversity trial during the beta I downloaded your 'XpressoMaker' script (the Morph Tag to Xpresso one would be really useful for me on rigging jobs) but it never worked for me. I tried it with the morph tag selected, the morph tag and xpresso tag selected, etc but it never created the output ports for some reason and I didn't seem to get any errors in the console to help debug.
Now I can watch the tutorials again (which I didn't watch all the way through at the time, I was in a hurry so I grabbed the finished example files) but I can't download the files (as you explained).
I'm just wondering, did anyone else find that those scripts didn't work for them? Maybe because they were created in R12 they broke in R13/14 due to changes in the SDK? Just wondering if there's something simple to change in the script to make them work again?

EDIT- I remembered I still have R12 installed on one machine here so I tried the Xpresso maker script, and it works fine in that, just select the object with the pose morph tag, run the script and it does everything - it creates an xpresso tag, adds the pose morph node and the target inputs. But in 13.061 it fails, t does create the xpresso tag, but no nodes are created inside that. After playing around a bit I discovered that it does then work if you manually drag the pose morph tag into the xpresso window, select that and then run the script again, the ports then get added. Seems to work the same way in R14 too. Weird (the comments in the script say it was created in 13.058, maybe there was a SDK change in 13.061) , but hopefully that will help someone else who wants to use it.

Cheers,
Brian

Last edited by Horganovski : 11-14-2013 at 10:09 PM.
 
Old 11-14-2013, 10:14 PM   #18
jimzepellin
Lord of the posts
 
jimzepellin's Avatar
James Leaburn
Bridge Officer
Dundee, United Kingdom
 
Join Date: Apr 2003
Posts: 626
Brian. If you go to the second video in the series the link is on that page.
__________________
If in doubt scream and shout.

C4D XL, ZBrush, Motion Builder
 
Old 11-14-2013, 10:25 PM   #19
Horganovski
Freelance Animator/Rigger
 
Horganovski's Avatar
portfolio
Brian Horgan
Graphite9
Dublin, Ireland
 
Join Date: Apr 2007
Posts: 4,852
Thanks Jim, missed that. It's the same version I downloaded last year though so that bug is still there unfortunately. Not a biggie though if you know to add the morph tag to the xpresso window manually, it works fine then (adding the ports is the important bit as it's the part that gives you RSI when rigging a face, heh, and it does work, just not as simply as it does in R12).

If anyone is taking requests for Cineversity tuts by the way.. top of my list is more Python stuff, the most recent one seems to be those xpresso maker ones, from summer 2012 The intro ones from Rick and Bret were great.. but need more!

Cheers,
Brian
 
Old 11-15-2013, 07:03 PM   #20
RickBarrett
Talking Head
Rick Barrett
MAXON Inc.
USA
 
Join Date: May 2002
Posts: 555
Is your PoseMorph tag selected when you run the script? It seems to be working here as long as the PoseMorph tag is selected (the script loops through the document's active tags - it should probably present a warning message if no tags are selected, but I always forget to add stuff like that).

As far as more Python tutorials, there are two in the pipe right now. You'll likely see one of those before Christmas, and the other early next year. We're in the process of making some changes to hopefully ramp up production in 2014, as well as spruce up a few sections of the site.
 
Old 11-15-2013, 07:56 PM   #21
Horganovski
Freelance Animator/Rigger
 
Horganovski's Avatar
portfolio
Brian Horgan
Graphite9
Dublin, Ireland
 
Join Date: Apr 2007
Posts: 4,852
Ah thanks Rick, it does work indeed if you select both the object and the pose morph tag on it, cool. Weird that in R12 you only have to select the object but not a problem really.

That's good news about more python tuts, look forward to them. One subject I'm particularly interested in is coding GUIs which seems quite tricky in C4D.

Cheers,
Brian
 
Old 11-15-2013, 07:56 PM   #22
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:56 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.