[Newbie Q] Material Deform does not work

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 04 April 2013   #1
[Newbie Q] Material Deform does not work

As you can see in the Attribute Manager, the material has spikes but when I hit render, it does not appear in the material in the viewport.

Why is that? :/

Reference Image:
 
Old 04 April 2013   #2
This might be a bug when using Displacement with certain primitive objects. I couldn't get a primitive sphere to render displacement at all (and I checked Render Settings and so forth) but a primitive cube had no issues. It worked on the sphere as soon as it was made editable.

Anybody?
__________________
Greebler | InterPoser

C4D-R16, VS2012, Xcode 4.6
 
Old 04 April 2013   #3
Just tried it with both primitives using noise in the displacement channel with uv mapping projection. Displacement renders in both if I use sub-polygon displacement. The sphere can't have render perfect enabled.
 
Old 04 April 2013   #4
That sorted it. It would make more sense to me if "Render Perfect" was ignored when displacement is affecting it - instead of having to remember to disable it. Yes, the docs note this to an extent but it isn't obvious.
__________________
Greebler | InterPoser

C4D-R16, VS2012, Xcode 4.6
 
Old 04 April 2013   #5
I still couldn't get the look I want, but I managed to make a distorted look, which is fine for me.
By unticking the render perfect and deleting the phong tag.

Thanks guys!
 
Old 04 April 2013   #6
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 04:58 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.