IK - Spline ?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 04 April 2013   #1
IK - Spline ?

Is there a way to get a spline to affect the IK other than PLA? Deformers will alter the spline, but it doesn't transfer to the bone chain.
 
Old 04 April 2013   #2
Yep! It's really easy:

Click on the Spline-IK tag, and you'll see a tab for "Handles" in the Attributes Mananger.

Depending on how many points are in your control spline, you can create nulls to use as "Handles" that will then attach that point of the spline to the null position.

You can make as many handles as you want (so long as there's points in the spline for them), by just clicking the Add button, and dragging a new null into that spot.

The index number refers to the point index on the control spline (basically, to which spline vertex do you want that null to control.
__________________
I'm a gun for hire... My work & gallery.
 
Old 04 April 2013   #3
Actually, an even easier way to do this, is simply click the Create button, and it'll produce a null and increase the point index by 1 everytime you create a new handle.
__________________
I'm a gun for hire... My work & gallery.
 
Old 04 April 2013   #4
He wants to use a deformer on the spline, and the spline in turn affect the IK spline, which is not possible as far as I know.
There's probably a way to have the IK spline Handles follow the deformed spline, which in turn will drive the IK spline expression.
I'm finishing a project and I'll make an example file.
__________________
One on one Online Instructor for Cinema4D | Visit www.Fluffy4D.com for more info.
 
Old 04 April 2013   #5
I believe this is what he may be trying to do:

Spline to Joints

If not, it's a pretty handy technique. Requires some xpresso setup, but it makes sense in the end.

Hope this helps!
 
Old 04 April 2013   #6
That's weird that deformers wont effect the joints attached to the spline. I guess a limitation (or one of those priority issues that we see a lot in Cinema) of the spline IK tag itself. It's strange though, if I add a Spline Dynamics tag to the spline the spline IK joints do see it, so really it seems like a bug/limitation to me rather than proper behavior that it ignores deformers and mograph effectors.

Cheers,
Brian
 
Old 04 April 2013   #7
Yeah, seems like a weird limitation.
Anyway, here is a quick test that works. The Xpresso could be a lot better with iteration nodes, but I'm too dumb/tired to figure it out right now.
There are also some priorities issue which I can't seem to fix.

Hopefully that will be a bit helpful nonetheless.
__________________
One on one Online Instructor for Cinema4D | Visit www.Fluffy4D.com for more info.
 
Old 04 April 2013   #8
Here is another workaround. Looks like it has a frame delay as well.
 
Old 04 April 2013   #9
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 06:52 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.