Rendering particles with Hair mat + Phys Renderer

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

Thread Tools Display Modes
  01 January 2013
Rendering particles with Hair mat + Phys Renderer

I am using the particle rendering technique in which a hair material and a hair render tag are applied to the particle geometry object. (no actual geometry)

Results look fine in editor window with physical renderer on (and with Use Render LOD with Editor window toggled on)

I can render the sequence fine to the picture viewer using the standard renderer, but for some reason I get no particle results when I use the physical renderer. What is also strange is that I am only having this trouble on a particular computer (Mac Pro 2 x 2.66Ghz 6-core Intel Xeon i.e.: 12 core.)

I can render particles to the picture viewer with the physical renderer on my 2008 Mac Pro 8-core, no problem.

Any suggestions?

Last edited by JoelDubin : 01 January 2013 at 08:55 PM.
  01 January 2013

I dont know how I fixed it exactly, but turning on and off DOF, switching back and forth between standard and physical renderer in conjunction with howling at the moon seems to have done it. Rendering fine now.

Maybe its just a buggy workflow.
  01 January 2013
Sometimes you will get "could not allocate particles"-errors when switching to physical renderer. I don't know why this happens, but increasing the allowed amount of particles in the tp settings isn't the problem here..

Last edited by Mr.Tyler Durden : 01 January 2013 at 11:20 AM.
  01 January 2013

--still getting erratic results.

now I'm getting completely different results in the picture viewer than in the editor. Upped the max particle count to handle the ~600,000 particles being generated, but the behavior is completely off to what it should be.
  01 January 2013
Obeardy's pCahce did the trick
  01 January 2013
Ah, so I think this has something to do with the timing.
Are you using thinking particles or external sequences btw?
  01 January 2013
Originally Posted by Mr.Tyler Durden: Ah, so I think this has something to do with the timing.
Are you using thinking particles or external sequences btw?

I'm using thinking particles.
In my first post the particles were not showing up at all in the PV. That was fixed--albeit accidentally.

In this new case, with a different setup, the particles DO render to the PV but are not behaving as they should---different than their behavior in the editor playback. Could be some user error somewhere in the xpresso or settings but couldnt figure out the problem.

After running pCache however, the particles cached correctly (cache saved internally to the file--making it huge) and rendered as expected.

The ability to retime the particles within the plugin is also very usefull. VERY happy with this plugin.
  01 January 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
Thread Closed share thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Society of Digital Artists

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump

All times are GMT. The time now is 01:00 PM.

Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.