CGTalk > Software Specific Forums > Maxon Cinema 4D
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 01-02-2013, 02:04 PM   #1
Gatisk
Veteran
 
Gatisk's Avatar
portfolio
Gatis Kurzemnieks%2B
freelance artist
Seattle, United%2BStates
 
Join Date: Dec 2003
Posts: 43
Send a message via MSN to Gatisk
Unhappy Multipass specular megaproblem!?

I am having big problems with getting useful results out of C4D multipass rendering system.

When rendering in multipass, specular pass does not catch any shadows and there are visible specular highlights in places where shadow falls. Because scene has multiple lights, the shadow pass is not completely dark in some areas and so - when multiplying over the specular pass, there is still some specular visible in the shadow parts. But there should be no specular highlight in the shadow, because specular is generated from each single light, and if that light is not visible, there should be no specular at all - even if some other light is shining in that place.

I attached sample picture showing the problem - taken from Cinema Picture viewer with default multipass settings. On the left is single pass rendered image and on the right is combined multipass image.
As you can see - differences are quite big. You can reproduce this quite easily with 2 lights and shadows enabled.

Also I discovered that, for example in Maya, specular pass takes shadows in account, so there are no specular in shadowed parts (in pure specular pass), so final comp is correct. But i can't find any way to do this in Cinema. Blend channels pass is not working as it is just a multiply of the same incorrect passes.

The only solution I found working is enabling separate lights option - therefore each light has it's own shadow pass that is completely black and masks out specular, but this is not useful when I have many lights in scene (impractical)

Any help or ideas would be appreciated. Otherwise this makes multipass rendering completely useless in C4D.
Attached Images
File Type: jpg specular_problem.jpg (55.7 KB, 105 views)
__________________
www.kurzemnieks.com
 
Old 01-02-2013, 04:42 PM   #2
LucentDreams
lover of gophers
 
LucentDreams's Avatar
CGSociety Member
portfolio
Kai Pedersen
Lighting TD
Double Negative
Vancouver, Canada
 
Join Date: Mar 2002
Posts: 10,350
It is annoying for sure. Amazing how many years I went without really noticing it. Didn't become aware of it myself until helping a student on a project last year. You can use the shadow pass as a mask for the specular passes as a solution. Convoluted for sure, but such is several of C4D's multipass outputs.
__________________
Quote:
"Until you do what you believe in, how do you know whether you believe in it or not?" -Leo Tolstoy
Kai Pedersen
 
Old 01-02-2013, 04:44 PM   #3
mart1jn
Expert
portfolio
Martijn Paasschens
Austin, USA
 
Join Date: Apr 2004
Posts: 202
I've never noticed this before, but after a simple test I see that the specular multipass is indeed not correct with shadows.

A workaround is to use lumas in the luminance channel for the specs. You can then add a multipass:Material Luminance. That does work with specular and shadows.
Unfortunately that only works if you have nothing else in the luminance channel.

cheers,
Martijn
 
Old 01-02-2013, 06:17 PM   #4
Gatisk
Veteran
 
Gatisk's Avatar
portfolio
Gatis Kurzemnieks%2B
freelance artist
Seattle, United%2BStates
 
Join Date: Dec 2003
Posts: 43
Send a message via MSN to Gatisk
Thank you - Lumas shader really works as a workaround. Just not very handy.

It is really strange that this issue is still not fixed in release 14. How could they sell the application that is fundamentally broken? Also I'm having issues with the white border around objects in shadows and the "shadow correction" setting seems to have absolutely no effect.

Do you know if VRAY for C4D works correctly in multipass?

I'm very sad. I started to like c4d very much (switched from Maya) but this is a serious dealbreaker.
__________________
www.kurzemnieks.com
 
Old 01-02-2013, 07:07 PM   #5
interactiveBoy
Expert
 
interactiveBoy's Avatar
portfolio
Gary Ingle
Animator / Graphics Generalist
Nashville, USA
 
Join Date: Jul 2005
Posts: 710
There are some things in Cinema 4D that have created issues in our production pipeline. I'm always shocked when no one else has run across some of these issues that we face almost daily.

I am very hopeful that some of these things will be taken care of in upcoming updates. If issues go unnoticed though, they can't be fixed, so please submit this to the suggestion form so that the developers will be aware of the issues.

I've submitted 3 or 4 today alone, and will submit another with this issue.

http://www.maxon.net/support/suggestions.html
 
Old 01-02-2013, 07:36 PM   #6
leed
Know-it-All
 
leed's Avatar
Lee David
buzzbox
cardiff, United Kingdom
 
Join Date: Apr 2003
Posts: 367
Not sure if it will help with this but I have been looking to develop
http://cinemaplugins.com/c4d-plugin...-smart-shaders/
into our workflow, I think it holds a lot of possibilities ...

Have you tried it without specular and using reflection instead. with a visible element to represent the lights?

Vray has a few issues with AA in multi pass....

Lee
__________________
http://www.buzzbox.eu
 
Old 01-03-2013, 08:44 AM   #7
Gatisk
Veteran
 
Gatisk's Avatar
portfolio
Gatis Kurzemnieks%2B
freelance artist
Seattle, United%2BStates
 
Join Date: Dec 2003
Posts: 43
Send a message via MSN to Gatisk
Smart shaders looks really cool, but I think they don't fix the specular pass issue.
__________________
www.kurzemnieks.com
 
Old 01-04-2013, 11:47 AM   #8
Gatisk
Veteran
 
Gatisk's Avatar
portfolio
Gatis Kurzemnieks%2B
freelance artist
Seattle, United%2BStates
 
Join Date: Dec 2003
Posts: 43
Send a message via MSN to Gatisk
Smile

Heh - I thought of new workaround with lumas shader.

Just put lumas shader in specular color and enable only one specular in it - make it as big as possible - 100% bright (to cover mostly everything). You can use layers to multiply with real specular texture. Change specular params as normal. That is it - specular pass will now be correct, because lumas shader generates shadows as needed!
Main advantages are that specular is still visible and correct in viewport and the render pass is also specular layer. Also the luminance channel is not used.
__________________
www.kurzemnieks.com
 
Old 01-04-2013, 11:47 AM   #9
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:32 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.