Visual Selector problem from R12 to R14

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 11 November 2012   #1
Visual Selector problem from R12 to R14

I am having an issue with some models that I show for a class. The visual selector (which worked fine in R12) is not showing up properly. When I double click on the visual selector tag in my object menu, the window comes up, but no bones or image show up.

Any ideas what is going on?

Thanks in advance for any suggestions.

Jeff Davidson
 
Old 11 November 2012   #2
I've noticed this as well when opening R12 or earlier files with Visual Selector tags in R13 or newer- it seems when the visual selector tag was changed in R13 it made older visual selector tags unusable. I never figured out a way to get the tags working properly- all the hotspots are listed in the tag but they don't show up on the image- so you pretty much have to do the whole thing over.
__________________
-
M dot Strange
Independent CG Filmmaker & Game Developer
M dot Strange dot CoM
 
Old 11 November 2012   #3
Bummer

Wow... that's depressing. These files are the files provided on their own Cineversity site!

Anyone else have any info on this?

Last edited by mrdcrestview : 11 November 2012 at 01:35 PM. Reason: forgot sentence
 
Old 11 November 2012   #4
Just to clarify, Cineversity is run by Maxon USA, not the guys developing C4D, although I'm sure they talk to each other Best thing to do would be to contact Cineversity and ask if there's a solution, or post on the forums.

cheers
brasc
__________________
brasco on vimeo
 
Old 11 November 2012   #5
Ah... I see. Thanks for the input, but the same issue shows up with the models provided in their content browser inside of Cinema4D.

Thanks,

Jeff D.
 
Old 11 November 2012   #6
Unfortunately the rigs in the content browser rarely if ever get updated. Poor old Flabio for example has a broken spine rig 'out of the box' for as long as I can remember him being in there.

As Ryonosuke11 said, R13 broke compatibility with the Visual selector and older versions, so the only way is to rebuild it from scratch.

Cheers,
Brian
 
Old 11 November 2012   #7
Originally Posted by mrdcrestview: Wow... that's depressing. These files are the files provided on their own Cineversity site!

Anyone else have any info on this?


Which series?
Some videos were made in older versions, and we can't know every little thing that has changed.
Your post on Cineversity also fails to mention which series.
If you can provide that information we can update the files.
Thanks
__________________
The views expressed in this post are by no means the opinion of those making the post or of any one person in particular.
 
Old 02 February 2013   #8
What if I wanted to rebuild the old visual selector with its behavior from R12?

Somehow hacked together with user data+xpresso+scripts? Or is it even possible without hiring a programmer to create a plugin?

I really love the old visual selector- I'm able to animate and work very fast with it and I can't use the same workflow with the new visual selector from R13 on.

Any ideas appreciated. Thanks.
__________________
-
M dot Strange
Independent CG Filmmaker & Game Developer
M dot Strange dot CoM
 
Old 02 February 2013   #9
What functionality are you missing?

PS.
As a side note, the files in question on CV are updated, with the help of another user who let me know which files were affected. The affected files are available on the CV forums.
__________________
The views expressed in this post are by no means the opinion of those making the post or of any one person in particular.
 
Old 02 February 2013   #10
I made a youtube video showing the functionality that I'm missing in the newer versions. If you have any suggestions on how to get it back or know of a better workaround than what I'm doing that would be awesome. Thanks.
__________________
-
M dot Strange
Independent CG Filmmaker & Game Developer
M dot Strange dot CoM
 
Old 02 February 2013   #11
Originally Posted by Ryonosuke11: I made a youtube video showing the functionality that I'm missing in the newer versions. If you have any suggestions on how to get it back or know of a better workaround than what I'm doing that would be awesome. Thanks.


The double clicking is interesting that doesn't work. But to be perfectly honest, the dropdown is going to be easier and faster. Imagine a scene that has just a buttload of objects in there and you're animating different things. Well hunting down your character will take longer than adjusting the drop down that would always be visible.

The other issue you mention actually exists in the older one and you can see it in your video. By default it will first switch to the tool in the AM. if you click it again, then you see your object. Youll see your object until you switch tools and click a button again. In R13+ you select an object you cannot keep clicking it. A better workflow is to use a second AM which is my preferred method of working. Set this second AM to only display object properties. That way no matter what you do, you have access to whatever object is selected. Often switching between move and rotate will lose the object focus in the AM, which is a real pain when you are moving say a hand or foot which can have not only moving and rotating, but also User data you wanna adjust. So the second AM always assures me that I have access to that information all the time, but if I need to see tools or other settings, I can go back to the first AM.

Hope this helps.
__________________
www.bretbays.com
"We do not - not wag our genitals at one another to make a point!"
 
Old 02 February 2013   #12
Originally Posted by xfon5168: The double clicking is interesting that doesn't work. But to be perfectly honest, the dropdown is going to be easier and faster. Imagine a scene that has just a buttload of objects in there and you're animating different things. Well hunting down your character will take longer than adjusting the drop down that would always be visible.

The other issue you mention actually exists in the older one and you can see it in your video. By default it will first switch to the tool in the AM. if you click it again, then you see your object. Youll see your object until you switch tools and click a button again. In R13+ you select an object you cannot keep clicking it. A better workflow is to use a second AM which is my preferred method of working. Set this second AM to only display object properties. That way no matter what you do, you have access to whatever object is selected. Often switching between move and rotate will lose the object focus in the AM, which is a real pain when you are moving say a hand or foot which can have not only moving and rotating, but also User data you wanna adjust. So the second AM always assures me that I have access to that information all the time, but if I need to see tools or other settings, I can go back to the first AM.

Hope this helps.


Thanks for the tips Bret! I'm going to give the second AM thing a shot and see how it goes.
__________________
-
M dot Strange
Independent CG Filmmaker & Game Developer
M dot Strange dot CoM
 
Old 02 February 2013   #13
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 08:52 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.