CGTalk > Software > Maxon Cinema 4D
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 10-07-2012, 07:27 PM   #1
swire
Veteran
portfolio
Sam
Norway
 
Join Date: Jan 2012
Posts: 33
[Simple problem]Realflow + Cinema 4D Particle Importer

Hello people!

I'm currently digging myself deep into the liquid world of RealFlow but I've stumbled upon an issue.

When I create a Sphere emitter with different daemons attached then import it with the Particle importer non of the particles appear in Cinema 4D.

If I just change the Sphere Emitter into a basic Circle simulate it then everything works fine, but not with the Sphere Emitter.

Could anyone else just quickly try importing a tiny simulation of particle with the sphere emitter into Cinema 4D and see if it works for them, I can't find anything online about this.

Extra info: The Sphere emitter is animated in the X and Y axis.

Thank you!
 
Old 10-07-2012, 09:21 PM   #2
ChristianZ
PRO
 
ChristianZ's Avatar
portfolio
Christian Z
Bern, Switzerland
 
Join Date: Dec 2004
Posts: 153
Yepp, works. I have just tested it with RF6.0.2 (2012) and C4DR14. I guess it is a workflow problem such as using the correct file sequence for import or something like that.
 
Old 10-08-2012, 11:53 AM   #3
swire
Veteran
portfolio
Sam
Norway
 
Join Date: Jan 2012
Posts: 33
Quote:
Originally Posted by ChristianZ
Yepp, works. I have just tested it with RF6.0.2 (2012) and C4DR14. I guess it is a workflow problem such as using the correct file sequence for import or something like that.



Thank you so much for your response Christian!
Ok just to make sure I've not done something outrageously stupid I'll summarize the short.
  1. Simulate the animated Shpere Emitter.
  2. Save the project, open Cinema 4D.
  3. Put the "Realflow particle importer" in the object window
  4. Import the list of .BIN files from the Particles folder from my Project.
  5. Then VOILA!

Have I missed something!?

I use the same version of Realflow only Cinema 4D R13...
 
Old 10-08-2012, 02:34 PM   #4
fuat
Expert
 
fuat's Avatar
Fuat YŁksel
FX TD
Trixter
Munich, Germany
 
Join Date: Jan 2006
Posts: 619
works here fine with R13 and R14, too.
maybe check the settings in the ParticleSettings: Max Particles, View Type (None?).
or upload the reduced scene file (bin loader only with no geometry, models, materials, cameras etc) plus a few of the particle-bin-files (10 should be enough) and i can have a look if you want.
cheers
fuat
 
Old 10-08-2012, 03:28 PM   #5
swire
Veteran
portfolio
Sam
Norway
 
Join Date: Jan 2012
Posts: 33
Quote:
Originally Posted by fuat
works here fine with R13 and R14, too.
maybe check the settings in the ParticleSettings: Max Particles, View Type (None?).
or upload the reduced scene file (bin loader only with no geometry, models, materials, cameras etc) plus a few of the particle-bin-files (10 should be enough) and i can have a look if you want.
cheers
fuat


Thanks mate, but I solved it.

But it doesnt make any sense for me but here I go might be a person out there that might've be in my situation.

The Geometry Scale was correctly set at 0.01 in RF and this works perfectly with particle from 2D emitters (Circular, rectangular and so forth.) but the 3D ones not so much.

Instead I kept the 0.01 geometry scale in RF and when I imported the particles into Cinema 4D I changed the "Scale" from 1 to 0.01 too. And that worked great.

TL;DR In the Real Flow Particles Importer, change the scale to 0.01 in Cinema 4D and the Geometry scale to 0.01 in Real Flow.
 
Old 10-08-2012, 05:02 PM   #6
fuat
Expert
 
fuat's Avatar
Fuat YŁksel
FX TD
Trixter
Munich, Germany
 
Join Date: Jan 2006
Posts: 619
glad you solved it.
yes, the unit-scale issue is old and well known but still annoying (cinema units 100 x bigger than RF units), you are right indeed.
but didnt you (in your initial post) say the particles didnt show up at all?
 
Old 10-08-2012, 08:42 PM   #7
swire
Veteran
portfolio
Sam
Norway
 
Join Date: Jan 2012
Posts: 33
Quote:
Originally Posted by fuat
glad you solved it.
yes, the unit-scale issue is old and well known but still annoying (cinema units 100 x bigger than RF units), you are right indeed.
but didnt you (in your initial post) say the particles didnt show up at all?


Yes, I was incorrect and this is also how I figured it out actually.
When I imported the particles my computer became bit sluggish, and I assumed by that I had particles loaded and I rendered then out some simple hair particles to get vision of them in the view port. Dussin frames in I see one single particle on the far edge of the screen. Scroll for an eternity back to further zoom my view port out and I notice another on the other side of the screen.

Then I changed the scale, saw the result and smacked my face repeatedly into the closest concrete wall.

I should also say that I had 0.01 in Geometry Scale all along in RealFlow just not in C4D.

Thank you Fuat and Christian for your time and help!
 
Old 10-09-2012, 08:30 AM   #8
fuat
Expert
 
fuat's Avatar
Fuat YŁksel
FX TD
Trixter
Munich, Germany
 
Join Date: Jan 2006
Posts: 619
Quote:
Originally Posted by swire
I should also say that I had 0.01 in Geometry Scale all along in RealFlow just not in C4D.


this is actually the most crucial setting in rf when working with cinema.
glad you solved it.
ciao
 
Old 10-09-2012, 08:30 AM   #9
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 08:55 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.