Auto replace lost tracks doesn't seem to work

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
  2 Weeks Ago
Auto replace lost tracks doesn't seem to work

Hello guys, I'm new to C4D so excuse me if I'm asking something dumb.

When I try to track any shot, individual tracks get lost after a few frames and not replaced by new ones, so when I try to solve the camera, it kinda works until a certain moment in the timeline. I made sure that the "Auto replace lost tracks" option is checked.

I'm missing something but what?

Thanks,
Carlos R.
 
  1 Week Ago
Hi Carlos,

Its hard to tell what's going on without getting to see the footage. "Auto replace lost tracks" is trying the keep the overall amount of tracks constant by adding new ones when others die. In practice you will likely not end up with a 1 to 1 replacement though. You can disable all the filters (2d Tracking > Filter Tracks) to check if any new ones were created. But that is not gonna help you with your scene as they were most likely removed for a reason.
It could also be that your footage is not suitable for (auto) tracking. E.g. fast camera moves that introduce a lot of motion blur can be problematic.

That's all I can think of without having a look at the footage.
 
  1 Week Ago
Originally Posted by carlosr: Hello guys, I'm new to C4D so excuse me if I'm asking something dumb.

When I try to track any shot, individual tracks get lost after a few frames and not replaced by new ones, so when I try to solve the camera, it kinda works until a certain moment in the timeline. I made sure that the "Auto replace lost tracks" option is checked.

I'm missing something but what?

Thanks,
Carlos R.
Hi Carlos,
if you create Auto-Tracks first then the auto-replace option is grayed out and won't be taken into account. You can either Re-Track your tracks, or delete them and run "Auto-Tracks" directly, that will create Auto-Tracks for you and auto-replace them as well.
 
  1 Week Ago
Originally Posted by 51M0N: Hi Carlos,
if you create Auto-Tracks first then the auto-replace option is grayed out and won't be taken into account. You can either Re-Track your tracks, or delete them and run "Auto-Tracks" directly, that will create Auto-Tracks for you and auto-replace them as well.
This was actually the solution to the problem. What's funny, is that C4D has the option activated by default, so I can't think of a logical reason why "Create" then "Delete" fixes this.

Anyway, Nuke has it's own weird behaviors too

Thanks guys!
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 02:23 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.