autoPack Visualization Challenge - Support Thread

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

REPLY TO THREAD
 
Thread Tools Search this Thread Display Modes
  01 January 2013
Originally Posted by gj210: BLENDER USERS:

We are looking for a few people to help us test the various Blender versions before releasing. Please contact me if interested.
info at autopack.org

We need Windows, Linux, and Mac testers for Blender 2.6.2. I have installation and tutorial pages ready to go, but to participate, I will ask you to provide feedback which means you will walk through a survey-tutorial to test most every major button.... 20-30 minutes of work for people new to autoPACK and ePMV.

I know we have TiZeta for Linux- anyone else? ro2563?
Thanks


Ah, great! I am a windows user. I will send you an e-mail
 
  01 January 2013
autoPack GUI

I'm not sure if anyone else is having this issue in Maya 2013 but the HIV viewer disappears every time I re-open the file. So I took some time to write a simple GUI to hide and un-hide ingredients.

You can get it Here.

This was only tested on Maya 2013.

As I add to it while I'm working, I will upload those as well at the same link provided above.

Quote: This will only work if you dont rename anything from the original autoPack creation

Last edited by ShawnFrueh : 01 January 2013 at 07:38 PM.
 
  01 January 2013
Originally Posted by ShawnFrueh: ...So I took some time to write a simple GUI to hide and un-hide ingredients.

Excellent work Shawn, I can't wait to try it out!
Thanks,
Graham
 
  01 January 2013
Hi,

So, I'm having trouble to load the HIV model - since i tried the earlier alpha I have taken the steps of uninstalling and then installing all components.
When I try to construct the HIV recipe I get the following:
"Could not find file
C:\Users\GunillaAppData\Local\Autodesk\3dsMax\2013 -64bit\ENU\plugins\MGLToolsPckgs\AutofillautoFillRe cipeScrpits\HIV\Hiv1.3.xml"

all I got there is hiv1.1.xml - any way I can find it and install it manually?


parts of the model loads though, with some but all details - the AFGui lists it as '1.0'

I suspect some of the problems is that I'm running Max Design 2013 and not Max 2013, I had to maually move some parts to make python work.

Any suggestions on how I fix this? I'd love to participate in this challenge.
__________________
B-Movie

WIP: Anatomy

Demoreel





Last edited by Gunilla : 01 January 2013 at 01:48 PM.
 
  01 January 2013
Originally Posted by Gunilla: I suspect some of the problems is that I'm running Max Design 2013 and not Max 2013, I had to maually move some parts to make python work.
Any suggestions on how I fix this? I'd love to participate in this challenge.


Hi Gunilla,
As far as I understand, SciViz does not support Max Design, only 3D Studio Max 2013, but it sounds like you got very far, so I'd appreciate it if you could tell me what you had to shuffle around in Python so I can test it here and maybe provide instructions for other Design users- never been tested until you. I can ask the programmers if they can adapt installers too.
In the mean time, could your problem be as simple as the misspelling of "...Scripts..." in the path you pasted for 1.3? In general it looks like you typed that path yourself, or made a new one, so I'd double check it, but maybe you just typed by hand for this forum.
For 1.1 did you see a half-shell HIV protein-only model like this? Otherwise, what was missing?
http://www.autopack.org/news/autopa...ilablefor3dsmax

Last edited by gj210 : 01 January 2013 at 07:16 PM.
 
  01 January 2013
Graham - yes, that's exactly what I got.
I messed things up a bit trying yesterday, but I will start over. Once done - I'll post you the steps for making it work.
There shouldn't be a problem to get it running in Max Design, in fact I managed to get the alpha running with no problems plus the 1.1 HIV
Do you have a direct link for the 1.3 so I can try it once I have the installment solved?

oh and yeah, the typo was from me manually typing it here. sorry
__________________
B-Movie

WIP: Anatomy

Demoreel




 
  01 January 2013
OK- So, the installers create a folder 3dsMax 2013/bin/assemblies/ with the files uPy.dll and uPy.pdb
I just copy those to the same locations within my Max 2013 Design folders.

To my knowledge Max and max design are identical apart for some archviz additions in Design and the API being included with Max, but I may be wrong

After installing ePMV and Autocell I get the following installed in my local directory

Full path is C:\Users\Gunilla\AppData\Local\Autodesk\3dsMax\201 3 - 64bit\ENU\plugins\MGLToolsPckgs\AutoFill\autoFillR ecipeScripts

I also tried copy the whole MGLToolsPckgs to my local 3dsMaxDesign folder but no change.

As you see I only have the old .xml files.
When trying today I cannot load even the half module I got yesterday, perhaps it was a remain from the alpha? I can use ePMV to load other .pdb files so it looks like the only thing missing would be the .xml file.

It would be great if you could make this work with Design as well - I do molecular rnderings regurlary and this will be a great addition to my toolset.
__________________
B-Movie

WIP: Anatomy

Demoreel




 
  01 January 2013
Originally Posted by Gunilla: It would be great if you could make this work with Design as well - I do molecular rnderings regurlary and this will be a great addition to my toolset.


the 1.3 and other result files are at http://code.google.com/p/autofill/s...2FHIV%2Fresults

When a file loads correctly, an interactive Viewer GUI should pop up.... sometimes autoPACK will hit a minor error late in the loading (like the dreaded 1.3.xml error) and the scene will partially load, but some textures and the GUI may be missing.

We actually uncovered a bug today that is being fixed where the 1.3 file was missing from the installation for Max. If a user followed the tutorials and HIV 1.3 was the first thing they ever tried to load, autoPACK would build HIV1.3.xml on the fly and then any other recipe could be loaded which is why we never caught this ourselves- sorry about that.

I'll try to talk you through a manual installation, but Autodesk said they will try to make a universal installer that will work for Design within a couple weeks if you prefer to wait. Christopher at Autopack confirms that you should be able to run with Design if you can set the paths correctly:

1) I know this is a huge pain, but I might suggest installing 3D Studio Max 2013 Demo http://www.autodesk.com/try3dsmax
because the .msi for SciViz and uPy will then unpack everything you should need into the correct folders, it will fix any permission issues with the folders, unblock the uPy.dll and upy.pdb files and set your python path for you... all correctly, and then you can just move them into your corresponding Design folders and delete the demo if you want. Some of that may be done by the .msi without having a Max to put things into- not sure.

Here are our old manual install instructions, but the .zip file no longer exists, so you'll have to get the components from the .msi as you've already succeeded in doing.:

2) Install Python 2.6.6 http://www.python.org/getit/releases/2.6.6/

3) Install SciViz- this will set a system-level python path for you... you can set this manually:
Create a PYTHONPATH environment variable set to the Python 2.6 folder (e.g. C:\Python26\)
http://www.katsbits.com/tutorials/b...em-variable.php
Note: Follow the linked instructions, but as noted in the details of the instructions change 22 in all the paths to 26

4) Install uPy (move it from Max Standard)
Remove the read-only flag from all files and folders and change the permission if needed (property->security).
Right Click and uncheck [ ] Read-only
Choose to apply to all folders and files in the next box
Unblock the file uPy.dll and uPy.pdb found in 3DSMax\bin\assemblies
http://www.develop-one.net/blog/200...InWindows7.aspx

Copy the contents of the package as follows
in the following instructions:
3DSMax folder you downloaded = uPyDL
maxpath = C:\Program Files\Autodesk\3ds Max 2013
put uPyDL/MaxPlus.py, and _MaxPlus.pyd into maxpath\
put uPyDL/bin/assemblies/uPy.dll and uPy.pdb into maxpath\bin\assemblies\
put uPyDL/plugins into your 3ds Max user documents folder:
for Windows Vista and Windows 7 - C:\Users\<username>\AppData\Local\Autodesk\3dsMax\2013 - 64bit\ENU\
If the path is not visible (AppData folder is hidden) use the Explorer window to type it in directly
for Windows XP - C:\Documents and Settings\<username>\Local Settings\Application Data\Autodesk\3dsMax\2013 - 64bit\ENU\

5) Follow the online instructions to access the plugin.
 
  01 January 2013
Lightbulb autoPACK for Blender released

An alpha version of the uPy plugin suite that contains autoPACK and ePMV for Blender has been released for testing and use in the autoPack Visualization Challenge: HIV in Blood Serum with installation instructions here:
http://www.autopack.org/install/blender-installation

Available packages include Mac, Windows, and Linux
Please update your autoPACK and ePMV software frequently and respond to the autoPACK forum if you have difficulties or find any bugs.

I've started a Blender-specific thread for the contest here.
 
  01 January 2013
run autoPACK simultaneously with Maya and 3d Studio Max

We just discovered that there is a python path conflict caused if you install SciViz (Python engine for 3D Studio Max) from Autodesk on the same Windows computer with Maya. This will soon be fixed by Autodesk, but in the meantime, it is possible to run both programs simultaneously by following this protocol:

1) Leave the PYTHONPATH Environment Variable that gets written by either SciViz or uPy's .msi as PYTHONPATH (Both installers create this path redundantly)
2) Start Max (you don't need to start the plugins)
3) After Max is running, change PYTHONPATH to PYTHONPATHmax so it becomes invisible to both Max and Maya (you can access the Python Path Environment Variable @ ControlPanel>SecurityAndSystem>System>SystemProperties>Advanced>EnvironmentVariable)
4) Start Maya

Anytime you start Maya, PYTHONPATH must be hidden as something like PYTHONPATHanything
and anytime you start Max, you need PYTHONPATH to be just plane PYTHONPATH
 
  01 January 2013
Thanks for your detailed instructions. I've followed as good as I can but got stuck. I tried downloading the HIV1.3 but now get the error message:

"the 'link' start tag on line 54 position 3 does not match the end tag of 'head'. Line 128, position 3"

I've no idea on how to fix this and unless you have a good solution for it I might just wait until the installer for design shows up and try a fresh start from there.

thanks
__________________
B-Movie

WIP: Anatomy

Demoreel




 
  01 January 2013
Originally Posted by Gunilla: I've no idea on how to fix this and unless you have a good solution for it I might just wait until the installer for design shows up and try a fresh start from there.


I forgot, have you tried to update both ePMV and autoPACK? The new version actually has HIV 1.3.xml included in the download instead of trying to build it on the fly. I don't think the paths will be an issue for the updater, but if they are or you can't even open either GUI in the first place, then yes, it may be best to wait a few days.
G
 
  01 January 2013
I have a non-technical question.
To run Autopack/Cellpack in 3ds Max 2013 you need the Autodesk Sci-Viz plugin, right?
But the Sci-Viz plugin will cease to function on May 1, 2013 (http://labs.autodesk.com/utilities/sciviz).
Is there anyway after May 1st to keep working with Autopack/Cellpack in 3ds Max? I'm asking this since I'm not very eager to dive into new software which can only be used for 4-5 months...although it is very tempting to jump in, looking at the results so far ;-)

Best regards,
David

Last edited by Raycat : 01 January 2013 at 11:24 AM.
 
  01 January 2013
OK - It seems like some weird caching has been going on, after several updates/restarts I now get something close to the full model. Some parts is still missing though, I keep trying some more and then I'll give it a rest until the new installer gets here.

thanks for the help
__________________
B-Movie

WIP: Anatomy

Demoreel




 
  01 January 2013
Originally Posted by Gunilla: OK - It seems like some weird caching has been going on, after several updates/restarts I now get something close to the full model. Some parts is still missing though, I keep trying some more and then I'll give it a rest until the new installer gets here.
thanks for the help


Can you tell me what parts of the model are missing? There are many filetypes involved in constructing the model into your scene- that will give me a clue. Also, try a fresh start, load autoPACK, load HIV 1.3, don't do anything else (too keep the listener short), then send me your MaxScript Listener and a screengrab of the GUI with the HIV in the background.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 06:49 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.