Nuke Merge (Over) Lowering Transparency

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2013   #1
Nuke Merge (Over) Lowering Transparency

Hey there,

I am trying to combine the merged 3D passes with the back plate on this matchmove shot, but everytime I merge the two (over) it lowers the transparency of the car.

Any Ideas?

Here are some screen shots viewing the two nodes I'm merging, then what the final merge looks like.





 
Old 02 February 2013   #2
Check the alpha channel of the car.
The B pipe is the one that keep the channels and it seems that you are using the alpha from the specular AOV (usually without alpha).
You could switch the inputs to use the B pipe from the beauty or just copy the alpha before the over.
 
Old 02 February 2013   #3
Here's a shot of the alpha channel of the car.

Does this look correct?

 
Old 02 February 2013   #4
not really.
It should look like the attached image.
Check if you are getting a correct alpha from any pass (probably the master beauty). If not, just render a matte for the object
Attached Images
File Type: jpg carAlpha.jpg (66.3 KB, 24 views)
 
Old 02 February 2013   #5
Right, yeah I thought that looked a little weird. I'll try to use my master beauty's alpha as a matte after class.

Which node would I use to turn my master beauty pass into a matte alpha?

Or would I just merge it in as an alpha pass?

Last edited by yoursham : 02 February 2013 at 05:38 PM.
 
Old 02 February 2013   #6
I like using a "copy" node to copy one pass alpha (or other channel) into the pipe (you could also use a shuffle copy).
Put it just before the over (B pipe connected) and connect the A pipe to you pass with the good alpha. Then set it like:

copy channel: rgba.alpha to: rgba.alpha (should be the default)
 
Old 02 February 2013   #7
Awesome! Thanks for your help!

One last thing, I'm getting that grey halo around the outline of the car. I know how to get rid of this in after effects, but don't know what to do in nuke so some help here would be greatly appreciated!!

Here's a pic.


Last edited by yoursham : 02 February 2013 at 07:38 PM.
 
Old 02 February 2013   #8
That seems a pre multiplication error and it could be many things.
A full screengrab of your network (or the script itself) would help greatly to debug the problem
 
Old 02 February 2013   #9
Yeah I figured it was something involving premults. Attached is my network.
Attached Images
File Type: png network.PNG (89.9 KB, 24 views)
 
Old 02 February 2013   #10
Why are you using so many merges with just one input and a mask? (Like Merge6, 7 and 9)
I think that it could be simpler and cleaner.
Also, what are you shuffling before the copy? And why are you premultiplying it? If it is not un-premultiplied you are premultiplying it twice.
 
Old 02 February 2013   #11
The pre-copy shuffle is shuffling out the alpha channel.

I realized that it is because I didn't unpremult it at the very top. I did some tests creating a new project and as you can see the attached has no premult issue. It must be something weird I'm doing with one of my masks as when I apply an unpremult at the top of my actual project nothing happens. I'll play around and keep you posted.
Attached Images
File Type: jpg premult.JPG (58.5 KB, 12 views)
 
Old 02 February 2013   #12
Yeah nothing happens because you need an alpha to unpremultiply and your passes don't have it (a part from the beauty).
As I said before, what you did with the masks is a little weird, there is surely a cleaner way. You could check the node guide to get started with the masks, alpha and premultiply.

Hope it helps and good luck!
 
Old 02 February 2013   #13
The first you should do before you do any grades and such is to add an "unpremult" node right under your Read node and set the "divide" parameter to "all". This way all your channels will be divided by the RGBA alpha. Then you can do your channel combinations and grades and when done you might want to copy back the original alpha from the read node (to make sure it has not been modified on the way) then "premult" and "over" your background.

-k
 
Old 02 February 2013   #14
You are right, but the problem that he is facing is that none of his passes has an alpha.
Only the master beauty has
 
Old 02 February 2013   #15
Originally Posted by nookie: You are right, but the problem that he is facing is that none of his passes has an alpha.
Only the master beauty has

I know. However, as I stated above using the "Unpremult" right after the multichannel Read node, and setting that unpremult node to "all", will divide all channels by the rgba.alpha not the individual channels' alpha (which apparently do not exist).
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:12 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.