Problem: Non planar mesh. Please help!!

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 04 April 2013   #1
Problem: Non planar mesh. Please help!!

I am working on making a temple in Maya to export to Mudbox for texturing. When I import it into Mudbox it says that I have some non planar faces or vertices. I applied a checker texture in Maya to see the result and it is very inconsistent. I have tried the cleanup tool with little success.

Here is a [IMG]render[/IMG]:

Please let me know if you can fix my problem I would deeply appreciate it.
 
Old 04 April 2013   #2
First of all, your image isn't working. Secondly, try using Mesh>Cleanup.
__________________
kevinbakercg.com
 
Old 04 April 2013   #3
Here are some pictures with more details

Thank you very much for your response. Here is the working link, sorry about the previous one. As you can see my textures only appear on some faces. The only solution I can come up with is that the extrusions at the bottom are unnecessary and should be removed? The cleanup did not help. If somehow we cannot come up with a solution, how would you go about modeling this type of geometry without any errors such as non planar issues? Thanks again for the help.

http://i1276.photobucket.com/albums...zps2f26b177.jpg
 
Old 04 April 2013   #4
Bottom View - - -http://s1276.photobucket.com/user/quentello/media/Non%20Planar%20Issue/NonPlanarIssue_Bottom_zps7f8cf1cf.jpg.html

Before Cleanup with 'bad faces' selected - - -
http://s1276.photobucket.com/user/q...df02fb.jpg.html

After Cleanup - - -
http://s1276.photobucket.com/user/q...c9dc3c.jpg.html
 
Old 04 April 2013   #5
Hi

Hello,
im not expert, but i think i know what is the problem that you have.
first, its always a good idea to take a SS of the error that you get.
i could see that you have triangles on top your temple, try to delete those edges and make them quads and try to send it to mudbox. also check face normals.

hope it helped,
if not, just post the SS of the error that you get from mudbox.

Best Regards,
Tal.
 
Old 04 April 2013   #6
Okay, so I imported the mesh into Mudbox and surprisingly, this time, I only got a high valence vertex error, which I don't think is a big deal (correct me if I'm wrong). But you can still see that the mesh is uneven in Mudbox. I find it strange that Maya tells me that I have non planar faces and Mudbox doesn't. To make things simpler, it could be my technique in modeling this pyramid that is incorrect. How would you go about modeling this correctly, so that I can import into Mudbox and start texturing without any errors? Thanks again.

--- http://i1276.photobucket.com/albums...zpscd79b9b5.jpg
---
http://s1276.photobucket.com/user/q...html?sort=3&o=1
---
http://i1276.photobucket.com/albums...zps1b369b5d.jpg

Sincerely,

Quentin Frere-Carossio

Last edited by quentello : 04 April 2013 at 02:23 PM. Reason: Forgot to put photo links
 
Old 04 April 2013   #7
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:08 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.