Unstable NVIDIA drivers while rendering

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 11 November 2013   #1
Unstable NVIDIA drivers while rendering

Hello everybody,
recently I armed a new workstation and Im having serious problems when rendenring (CPU, not Vray RT) my scenes (3DS Max 2012 + Vray 2.1), the NVIDIA drivers seems to be so unstable that it is impossible to complete a render, after several NVIDIA drivers crashes (with black screens), the computer gets totally freezed and I have to reset it manually. The unic solution I have found is to uninstall de nvidia drivers before rendering each image, what in fact it cannot be a final solution.

My config (nothing overclocked):
MB:Asus p9X79 pro
CPU:i7 4930k
RAM:16GB G.Skill DDR3 Ares Series 2400Mhz
GPU:EVGA NVIDIA GTX 770 4GB SC
PSU:Corsair AX860i 80Plus Platinum

I also tried installing old NVIDIA drivers and also render with 3DS Max 2014, still getting same crashes and freezes...

I was wondering if somebody else have had this problems or its only me and I have a defective GPU or something... Should I opt for another GPU?
Thank you very much in advance.

Last edited by knsin0 : 11 November 2013 at 10:59 PM.
 
Old 11 November 2013   #2
Test your card

I gotta believe that it's your video card. Nvidia drivers are solid. If you had an AMD card, that would be different. AMD's drivers are all over the map.

Try Furmark to test your Nvidia card. Here's a link.
http://www.ozone3d.net/benchmarks/fur/

Keep an eye on the temps as this software really heats up a Cuda card.
 
Old 11 November 2013   #3
Have you plugged both 6 and 8 pin connectors into the gfx card?
Does anything else cause the gfx card to crash, or just 3ds max?
Which render engine?
__________________
Matthew O'Neill
www.3dfluff.com
 
Old 11 November 2013   #4
what driver version.. nvidia drivers of late have been really really "iffy" in my book.
__________________
-- LinkedIn Profile --
-- Blog --
-- Portfolio --
 
Old 11 November 2013   #5
Nvidia's latest drivers have been bad. I updated mine and I had freezing, crashing, and blue screening. I quick look at the .dmp file showed that it was the Nvidia driver. So I installed an older driver and now everything works fine.
 
Old 11 November 2013   #6
A purely CPU bound task crashing the video subsystem is usually more of a consequence of power or heat issues of sorts than of bad drivers.

If you are NOT using the videocard and it doesn't randomly crash when you stress it it's not even possible for it to crash your system when it's doing nothing. More likely PSU, mobo, or cabling are not doing what they should and when the CPUs draw fully something goes tits up. Alternatively bios settings (a lot less likely but not impossible) or overheating (perfectly possible) can cause side effect style crashes.

The fact uninstalling drivers fixes it IMO is a red herring, it doesn't necessarily point to bad drivers (though a bad/dying videocard can cause any of the above issues) as much as show it's being hit hard by a side effect of something else.

What are the CPU, videocard and in-case temperatures when this happens? Do you have any way to monitor voltage of the various parts and see if any dip worryingly?
__________________
Come, Join the Cult http://www.cultofrig.com - Rigging from First Principles

Last edited by ThE_JacO : 11 November 2013 at 06:31 AM.
 
Old 11 November 2013   #7
Thank you everybody for your answers, I have been messing around these days and finally I solved it, the solution? Clean installation of windows 8.1 + driver updates for all the components (BIOS included). Im not sure about the cause of the problem, maybe some problematic drivers, who knows... Now everything seems to run smoothly, no freezes, no black screens! Thx and happy renderings!
 
Old 11 November 2013   #8
Originally Posted by ThE_JacO: A purely CPU bound task crashing the video subsystem is usually more of a consequence of power or heat issues of sorts than of bad drivers.

If you are NOT using the videocard and it doesn't randomly crash when you stress it it's not even possible for it to crash your system when it's doing nothing. More likely PSU, mobo, or cabling are not doing what they should and when the CPUs draw fully something goes tits up. Alternatively bios settings (a lot less likely but not impossible) or overheating (perfectly possible) can cause side effect style crashes.

The fact uninstalling drivers fixes it IMO is a red herring, it doesn't necessarily point to bad drivers (though a bad/dying videocard can cause any of the above issues) as much as show it's being hit hard by a side effect of something else.

What are the CPU, videocard and in-case temperatures when this happens? Do you have any way to monitor voltage of the various parts and see if any dip worryingly?


I've witnessed this first hand though where WDDM would throw TDR errors constantly after updating drivers. Even when apparently 'not doing' anything.. perhaps reading a webpage. By disabling tdr delays, it was really easy to return to the days of BSODs due to poor drivers. My first reaction was like you, must be temps or voltages.. but nope. It was definitely driver related to the video card.
__________________
-- LinkedIn Profile --
-- Blog --
-- Portfolio --
 
Old 11 November 2013   #9
Originally Posted by tswalk: I've witnessed this first hand though where WDDM would throw TDR errors constantly after updating drivers. Even when apparently 'not doing' anything.. perhaps reading a webpage. By disabling tdr delays, it was really easy to return to the days of BSODs due to poor drivers. My first reaction was like you, must be temps or voltages.. but nope. It was definitely driver related to the video card.

That's why I asked what driver version. But with that said I haven't seen a single report of such thing with any non beta driver with Kepler support, I was ruling out in his case, not generally.

And even when it is the drivers, of which there had been a similarly bad release not a year ago hitting 6x0 cards (been there, done that, swore the sky down at the card at the time), what it was messing with was the input management part of the firmware and if you logged the voltage it always corresponded with a spike and then a drop below what the card could downclock to cope with.

Kepler thermal management offsets the chances of the above even further and if it's unloaded it can deal with a ridiculously low power serve, so it's always worth going through bios versions and settings first and go conservative (and monitor) on all fronts, that way you can rule out the one unfixable and unavoidable, otherwise impossible to track case of odd interactions of not serving the card its required draw.
__________________
Come, Join the Cult http://www.cultofrig.com - Rigging from First Principles
 
Old 11 November 2013   #10
Originally Posted by ThE_JacO: And even when it is the drivers, of which there had been a similarly bad release not a year ago hitting 6x0 cards (been there, done that, swore the sky down at the card at the time), what it was messing with was the input management part of the firmware and if you logged the voltage it always corresponded with a spike and then a drop below what the card could downclock to cope with.
.


that's interesting, I noticed the same voltage irregularity in the most recent drivers (331.65) but on Fermi (5xx series).. perhaps it has dropped below their reference design limits.
__________________
-- LinkedIn Profile --
-- Blog --
-- Portfolio --
 
Old 11 November 2013   #11
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:05 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.