CGTalk > Technical > Technical and Hardware
Login register
Thread Closed share thread « Previous Thread | Next Thread »
 
Thread Tools Search this Thread Display Modes
Old 03-06-2013, 11:13 AM   #1
halfPintMike
Timshel
 
halfPintMike's Avatar
portfolio
Timothy Augustine
TCS
Chennai, India
 
Join Date: Dec 2008
Posts: 217
Banding in Windows 7

Hi there,

Recently my monitor's been having a noticeable banding of colours. I initially though that it was either my monitor or my graphics card but turns out it's my windows 7. Because, in Ubuntu, which I've also installed, I don't notice this banding at all. I've tried all the settings in windows that I know of but to no avail. And the worse thing is, I didn't even do anything significant with the settings to have caused all this banding!

Below is my set up:
Monitor: SyncMaster B2230
Video Card: Nvidia GTS 450
OS: Windows 7, Home Premium, 64 bit
Nvidia Driver: 314.07.

Does anybody know why this is happening? Has this happened before? Any help would be much appreciated. This banding really is annoying!

I'll provide any other detail that you may require.

Thanking you,
Timothy
__________________
O thou sculptor, painter, poet!
Take this lesson to thy heart:
That is best which lieth nearest;
Shape from that thy work of art.
-Longfellow
 
Old 03-06-2013, 11:32 AM   #2
imashination
Expert
 
imashination's Avatar
portfolio
Matthew ONeill
3D Fluff
United Kingdom
 
Join Date: May 2002
Posts: 8,821
Where is it happening in particular? eg. does loading an image in an image viewer do it? Only images in photoshop, just 3d?
__________________
Matthew O'Neill
www.3dfluff.com
 
Old 03-06-2013, 11:44 AM   #3
halfPintMike
Timshel
 
halfPintMike's Avatar
portfolio
Timothy Augustine
TCS
Chennai, India
 
Join Date: Dec 2008
Posts: 217
Hi imashination, thanks for the reply.

I'm noticing this everywhere. In my wallpaper, gimp, blender, the default image viewer, xnview and Photoshop elements. These are all the ones I have and went through them now to make sure.

I also logged into ubuntu to check again. Hardly any banding in ubuntu (normal for my monitor)

T.
__________________
O thou sculptor, painter, poet!
Take this lesson to thy heart:
That is best which lieth nearest;
Shape from that thy work of art.
-Longfellow
 
Old 03-06-2013, 01:18 PM   #4
imashination
Expert
 
imashination's Avatar
portfolio
Matthew ONeill
3D Fluff
United Kingdom
 
Join Date: May 2002
Posts: 8,821
Right click on the desktop, select the nvidia control panel and under the display resolution settings, check its set to 32bit instead of 16bit.
__________________
Matthew O'Neill
www.3dfluff.com
 
Old 03-06-2013, 02:52 PM   #5
halfPintMike
Timshel
 
halfPintMike's Avatar
portfolio
Timothy Augustine
TCS
Chennai, India
 
Join Date: Dec 2008
Posts: 217
Hi,

Yes, it is at 32 bit. Is there a way by which I can export all my settings into a file or something so I can upload it here? It'll be apparent where I went wrong in that way, I think.

Thanks,
T.
__________________
O thou sculptor, painter, poet!
Take this lesson to thy heart:
That is best which lieth nearest;
Shape from that thy work of art.
-Longfellow
 
Old 03-06-2013, 03:01 PM   #6
imashination
Expert
 
imashination's Avatar
portfolio
Matthew ONeill
3D Fluff
United Kingdom
 
Join Date: May 2002
Posts: 8,821
Not really, but as a staring point, take a screenshot of your desktop and put it somewhere as a png. That way we can tell if the desktop is generating banding, or if its just the display being a problem.
__________________
Matthew O'Neill
www.3dfluff.com
 
Old 03-06-2013, 03:19 PM   #7
halfPintMike
Timshel
 
halfPintMike's Avatar
portfolio
Timothy Augustine
TCS
Chennai, India
 
Join Date: Dec 2008
Posts: 217
Ok, I've attached the screen shot here. I've tested it with different monitors as well. This other monitor which does not produce any banding reacted the same way my current monitor does.

Here's the link for the destop image: Link
__________________
O thou sculptor, painter, poet!
Take this lesson to thy heart:
That is best which lieth nearest;
Shape from that thy work of art.
-Longfellow
 
Old 03-06-2013, 03:42 PM   #8
halfPintMike
Timshel
 
halfPintMike's Avatar
portfolio
Timothy Augustine
TCS
Chennai, India
 
Join Date: Dec 2008
Posts: 217
I think we're on to something! When I check the screen shot of windows' desktop in ubuntu, I'm noticing the same banding. I've placed the screenshot of the desktop and the image used as the background side by side in ubuntu. The one on the left is the desktop and as you may notice, it's banded while the image on the right isn't.

I wonder what went wrong...

Here's the image link: Link
__________________
O thou sculptor, painter, poet!
Take this lesson to thy heart:
That is best which lieth nearest;
Shape from that thy work of art.
-Longfellow
 
Old 03-06-2013, 04:53 PM   #9
greyscale
New Member
 
Join Date: Dec 2003
Posts: 1
try this

try resetting "Adjust desktop color settings" in nvidia control panel.

I could replicate your problem by using a very high contrast value.

-Greyscale-
 
Old 03-07-2013, 09:33 AM   #10
wiz4rd
Frequenter
 
wiz4rd's Avatar
portfolio
Marco Funk
Tuebingen, Germany
 
Join Date: Sep 2008
Posts: 161
Are you using the proprietary Nvidia driver for Linux, or are you on Nouveau.
Either way, it might be some strange driver issue.
 
Old 03-07-2013, 10:00 AM   #11
halfPintMike
Timshel
 
halfPintMike's Avatar
portfolio
Timothy Augustine
TCS
Chennai, India
 
Join Date: Dec 2008
Posts: 217
Hi wiz4rd,

I hadn't touched my drivers for months and there wasn't this banding then. It seemingly happened all on its own. So I updated to the latest version and still no difference. I'm guessing it's something I unwittingly did that caused all this, haha!

As for the nvidia drivers in ubuntu, I let ubuntu take care of it. It downloaded it on its own and has been the same for about a year, I should say.

Thanks,
T
__________________
O thou sculptor, painter, poet!
Take this lesson to thy heart:
That is best which lieth nearest;
Shape from that thy work of art.
-Longfellow
 
Old 03-07-2013, 10:18 AM   #12
imashination
Expert
 
imashination's Avatar
portfolio
Matthew ONeill
3D Fluff
United Kingdom
 
Join Date: May 2002
Posts: 8,821
The source image youre using of the vase, what format is it in? As a wild guess, if this is the only place it does it, then I might guess its a 16bit tiff youre loading as the backdrop, but windows is loading it and saving it as a jpg somewhere and using that version.

Open a 3d app and add a white sphere, show us a shaded image. Right now I suspect its just the image loading routines of windows making a hash of downsampling an image.
__________________
Matthew O'Neill
www.3dfluff.com
 
Old 03-07-2013, 01:57 PM   #13
tswalk
Expert
 
tswalk's Avatar
portfolio
Troy Walker
USA
 
Join Date: Jan 2012
Posts: 709
Quote:
Originally Posted by halfPintMike
I think we're on to something! When I check the screen shot of windows' desktop in ubuntu, I'm noticing the same banding. I've placed the screenshot of the desktop and the image used as the background side by side in ubuntu. The one on the left is the desktop and as you may notice, it's banded while the image on the right isn't.

I wonder what went wrong...

Here's the image link: Link


there's quite a bit of difference in those file sizes.. my guess is that the one on the left is 8/16bit while the one of the right is 32bit... that's why you're getting the banding.

when you installed the latest drivers, did you opt for a "clean" install (removing all profile settings?)
__________________
-- LinkedIn Profile --
-- Blog --
-- Portfolio --
 
Old 03-07-2013, 03:54 PM   #14
halfPintMike
Timshel
 
halfPintMike's Avatar
portfolio
Timothy Augustine
TCS
Chennai, India
 
Join Date: Dec 2008
Posts: 217
Hi,

@tswalk: I wonder why there is this file size difference. Both the screenshots were saved with a version of gimp that does not support images more than 8 bits. And yes, when I installed the drivers I did a "clean" install. (I thought it'd revert everything back to the original settings)

@imashination: The source image was a .bmp file. I think there lies one of the problems. When I resave the image as a .png and open it in Xnview, it looks the way it did in Ubuntu (with a little more banding than in unbuntu, but then this could be my imagination).

But the default image viewer and the desktop display it with banding.

So, suppose I have an image that has a very, very, very sooth gradient, would it still band if it were displayed in a good monitor? I'm asking all this because I have a feeling that this is the reason behind the whole problem. I'd been playing around with very weak lights when I first noticed the banding. I'm guessing that the lights were so weak that the renders banded anyway. Even if there were nothing wrong with anything.

As a test, I rendered the sphere lit by a very weak light source to get a banded render. And when viewed in ubuntu, it banded just the same way. What do you guys think?

Here is render of the sphere: Link

Thanks again,
T.
__________________
O thou sculptor, painter, poet!
Take this lesson to thy heart:
That is best which lieth nearest;
Shape from that thy work of art.
-Longfellow
 
Old 03-09-2013, 05:23 PM   #15
halfPintMike
Timshel
 
halfPintMike's Avatar
portfolio
Timothy Augustine
TCS
Chennai, India
 
Join Date: Dec 2008
Posts: 217
Hi there,

I looked harder. I definitely have something wrong with 7. I did a couple of test images and then compared to note a difference between 7 and ubuntu. I wonder if reinstalling the OS is a good idea.

Thanks,
T
__________________
O thou sculptor, painter, poet!
Take this lesson to thy heart:
That is best which lieth nearest;
Shape from that thy work of art.
-Longfellow
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:08 PM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.