Accidentally sculpted model with wrong UV set

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

Thread Tools Search this Thread Display Modes
  07 July 2013
Unhappy Accidentally sculpted model with wrong UV set

I use 3rd party program for UV mapping on my objects from 3ds max, once I map them I import them back to 3ds max and then to mudbox for normal map creation and painting. This time I made a mistake and accidentally sculpted the original object from 3ds max, without creating the proper UV map. It has a good UV set, since I didn't notice the mistake while sculpting, but it is not the UV set that I need. I really don't want to waste time on sculpting again since I'm on a tight schedule, my question is this: Is the a way to somehow replace the UV map in mudbox and retain the sculpting info for normal map generation? Objects are identical, vertex IDs are unchanged (I think )...

I know this is a longshot but I had to ask
  07 July 2013
File --> import uv
  07 July 2013

I've tried doing that, but some strange things happen to my mesh when I do that. I will do more research considering importing UV when I have the time, for now I've left that issue unresolved
  07 July 2013
In my experience Import UVs doesn't really work that well from max. Somewhere along the way Max re-orders the verts or vert/uv assignment ordering which messes this up.

But you can do it the other way round and transfer the sculpted detail from the original model to the new one that does have UVs.
  07 July 2013
Robin is right this could be the problem...
there is an optimize option in the max OBJ exporter wich is really bad...
turn all three options (vertex, normals, texture) off...
  08 August 2013
I've transferred the sculpting detail from model with UVs to model with proper UV set and it worked just fine. Had to do some minor tweaking in ps but it's all good now
  08 August 2013
Hi Oglu,

Quote: Robin is right this could be the problem...
there is an optimize option in the max OBJ exporter wich is really bad...
turn all three options (vertex, normals, texture) off...

I made a dinosaur head which i was really quite proud of. When I unwrapped, then imported my UVs from max. When I went to paint on the model, the paint was being applied in the wrong place. Could this be becasue I didn't turn those options off?

The UV map looked the same though, but there were like holes in my uvs in places for some unknown reason.

  09 September 2013
Hi guys, I didnt want to open a new thread because my problem is very similar to this one.

I sculpted a model first before doing the UVs thinking that it wont be a problem because I will do UV later and just use "import uv" option in mudbox. Thats what I did but it doesnt seem to work for me. I made nice clean UVs in maya and used import uv in mudbox as an .obj. Now UVs on my sculpted model looks exactly how i want them to look but the problem is when i try to extract maps. any kind of maps i try to do ao/normal/displacement i always get faceted/square artifacts all over my model. I checked exported maps in photoshop and they all are faceted. looks like the maps are exported from base mesh without any smoothing done.

For last few hours i was googling alot trying to find a solution and tried many things to go around that but it just doesnt work and i get the same result. trying import high res mesh as a layer gives me error about vertice count which doesnt make sense because its an exact same model with same poly count.. also i noticed that if i send my model from mudbox back to maya the uvs getting messed up, more accurate : UV shells are not intact for example if i try using a "move uv shell" option in maya's uv editor it doesnt select whole shell but parts of it...

its kind of dead end for me and looks like im gonna have to redo all the sculpting from scratch.. which really makes me wanna uninstall mudbox and go to zbrush..

please help.

Thanks, Simas.
  09 September 2013
Hi badboyz,

I am new to mudbox, but I have done what you are asking.

In mudbox. Take your subdivision levels down to zero, and then export it as an obj.
Load it into max, and create the uvs using unwrap uvw.

Make sure all your uv islands are at least 3 pixels apart.

export from max to obj, and then in mudbox use this obj to load the uvs from.

Then you can take mudbox up to the highest level and paint your texture.

Hope this helps. I am new at this too, but this worked for me.

  09 September 2013
yeah this works but all my sculpting done will be gone and i will have to do sculpting from 0 again..
  09 September 2013
Hi Badboyzz,

Quote: yeah this works but all my sculpting done will be gone and i will have to do sculpting from 0 again..

No your sculpting won't be gone. You can import the uvs, and go back up to your highest level, and your sculpting will still be there. Remember you are not changing the shape of the model, just the uvs. Your sculpting will still be there.

The model you exported to max at level 0 is the same one you are importing the uvs from.

So import your uvs at level zero, and then go up to the highest level, and all your sculpting will still exist.

I know because this is the process I used on my mudbox dinosaur.

  09 September 2013
I tried that and my exported maps were still faceted. Doing more research in last few hours I found this video:

this what was happening to my UV. basically importing/exporting might mess up ur UVs and at the end in mudbox all ur faces are seperated and not sewed together, thats why i was getting these wierd artifacts around every face on my model.

in the future i think ill get the UVs done first and only then go to sculpting.. this was a headache..

thanks anyway )
  09 September 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
Thread Closed share thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Society of Digital Artists

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump

All times are GMT. The time now is 10:05 PM.

Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.