Vray Weird Lighting Dots In Maya

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  08 August 2013
Question Vray Weird Lighting Dots In Maya

This is the pass of Vray environment fog. It shows weird lighting dots as the image showed below. And I google this problem on website. Most people said this weird spots caused by GI, but I don't even use indirect illumination. I really don't have idea... Dose anyone ever has this problem?

I use Rect_lights and apply Rect Tex.

 
  08 August 2013
Looks like low sampling of either your fog or lights.
 
  08 August 2013
Smile Sampling

Originally Posted by knekker: Looks like low sampling of either your fog or lights.



Knekker,

Thank you for your reply. I initially doubt sampling might cause that, but I don't know. The other pass work fine.

Here is my sampling setting.

 
  08 August 2013
Other Passes

These are different passes.
RGB pass shows a little bit lighting spots, whereas Totallight works totally fine. Only AtmosphereEffect pass for environment fog is out of control.

RGB


Total Light
 
  08 August 2013
the fog node that you added to your environment, whats the setting set to?
 
  08 August 2013
The Setting

Originally Posted by knekker: the fog node that you added to your environment, whats the setting set to?


Here is the Environment Fog setting.
 
  08 August 2013
Maybe Caustics?

I just look carefully the help of the environment fog in the official site.

http://help.chaosgroup.com/vray/hel...ironmentfog.htm

My problem really looks like this: related to volumetric caustics. I didn't turn on any indirect illumination attributes like GI and Caustics as I said, but I found the Rect_Light has the setting of photon emission, really doubt if this problem is connected to this setting.

Last edited by Timmons : 08 August 2013 at 10:41 PM.
 
  09 September 2013
Hi Timmons

I'm not sure but look the the color mapping seting et check the box Subpixel mapping. If your bright dot disapper the intensity of your light or the multiplier maybe to high.

Tell me if it working.
 
  09 September 2013
first I'd increase your fog's subdivs to 32-64 and see if there's any difference. Next I'd tick the clamp output checkbox under color mapping and give it a value no more than 10.

On a side note I would also lower the max subdivs to 8 and probably wouldn't go higher than 24 or so if need to.
 
  09 September 2013
Hi Warcha

Thank you very much for your reply. Yes, I turn Subpixel on under the color mapping tap of render setting and the weird bright dots are gone. I think light's intensity setting dose effects that, but I don't know, I mean if I decrease the light intensity, the look is not what I want. There is an image I set the light's intensity to 5, the light under castle works but that's not the look I want, and the area behind still doesn't work, still showing bright dots.



And here is the result I turn on Subpixel


Really appreciate your help.
 
  09 September 2013
Hi Panupat
Thank you for your helping hand. I try your guidance, here are the result.

Increase fog's subdivs 64



MaxSubdivs8


I think it seems no good results of what efforts I tried. Still appreciate your concern.
 
  09 September 2013
Hi Thimmons,

I have found this in a 2009 thread


1) If "sub-pixel mapping" is off, your result will be the average of the two colors, or (0.5+3.5)/2=2.0, then clamping is applied to give you the final pixel value of 1.0 (pure white).

2) If "sub-pixel mapping" is on, first the sub-pixel values will be clamped, and then they will be averaged together. So your final result will be (0.5+1.0)/2=0.75 (light grey)

So as you see this option really has the potential to alter the final image brightness.When working with HDR values, it is typically best to keep it off, so as to get a correct result.
 
  09 September 2013
Originally Posted by Warcha: Hi Thimmons,

I have found this in a 2009 thread


1) If "sub-pixel mapping" is off, your result will be the average of the two colors, or (0.5+3.5)/2=2.0, then clamping is applied to give you the final pixel value of 1.0 (pure white).

2) If "sub-pixel mapping" is on, first the sub-pixel values will be clamped, and then they will be averaged together. So your final result will be (0.5+1.0)/2=0.75 (light grey)

So as you see this option really has the potential to alter the final image brightness.When working with HDR values, it is typically best to keep it off, so as to get a correct result.


I saw this thread. I kind of confused, as everyone say it'd better turn it off, but in my case, it shows weird lighting spots. The weird lighting spots are gone when I turn it on.
 
  09 September 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:21 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.