CGTalk > Software Specific Forums > Autodesk 3ds max > Particle Flow
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 04-29-2013, 10:15 PM   #1
jobwallis
JuiceLoosner
portfolio
Job Wallis
Sydney, Australia
 
Join Date: Jul 2010
Posts: 103
Send a message via MSN to jobwallis
strange layer issues

Hi
I spent a few hours last night trying to work out why a particle effect was not working. I eventually worked out that it was contained as part of a hidden layer.
Un-hiding the layer makes the particles visible though I cant move them from the layer.
Not sure why. PFlow source icon is in correct layer and the object based emitter i am using are in the correct layer but the particles themselves remain in another layer. There is nothing in the layer list that refers to these particles either - weird.
Got no idea why they moved to this layer either.
Anyone know what's going on here?
 
Old 04-30-2013, 10:32 PM   #2
JohnnyRandom
Configurator
 
JohnnyRandom's Avatar
portfolio
John Rand
still wandering the binary void
salt lake city, USA
 
Join Date: Oct 2003
Posts: 5,000
Everything PFlow creates in teh Particle View has an invisible counterpart in the form of a helper.

For instance you can see them if in a new scene you create a Standard Flow and do a select all in the viewport. You will notice in the Command Panel that you have 13 Entities Selected, yet you only "see" the PF Source icon.

There are some script snippets out there that select all of these, as well as a few functions in max (Synchronize layers) that are supposed to deal with it in one way or another.

I wrote a script a little while back that will move everything to the layer that the PF Source is on and reports everything it did to the listener, I just cleaned it up a little, try it if you like, it does not have an interface yet, so just run from the maxscript run menu or open it in the editor and evaluate it.
Attached Files
File Type: zip PF_Moverator_v101.zip (1.2 KB, 4 views)
__________________
poof ~>Vimeo<~
 
Old 04-30-2013, 10:32 PM   #3
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:12 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.