CGTalk > Main > General Discussion
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 11-17-2012, 09:03 AM   #1
starbase1
Veteran
portfolio
Nick Stevens
Capacity Planner
Starbase1
London, United Kingdom
 
Join Date: May 2005
Posts: 39
How to get proper blacks in space animation?

I hope this is the right forum section, I really was not sure which was best!

Has anyone else run into the problem of blacks in video sequences coming out lighter when you render a sequence out?

It's really driving me nuts, as it seriously spoils the result. Yesterday evening I tried every codec I had in turn, and the only ones that delivered a proper deep bloack in space scenes were uncompressed, and that produced files so large no-one else will ever get to see them...

I overlaid two frame grabs to show the problem, result attached.

Is there a codec that will deliver deep blacks, or settings on one that will address the issue?

Commercial codecs are acceptable as long as the price is not too painful, and the results can be played on most home computers without additional downloads.

I'm using the cheap edition of Sony Vegas, (though I'm fairly sure its a codec issue).

Nick
Attached Images
File Type: jpg codec-problem2.jpg (73.0 KB, 140 views)
 
Old 11-17-2012, 09:09 AM   #2
darthviper107
Expert
 
darthviper107's Avatar
portfolio
Zachary Brackin
3D Artist
Precocity LLC
Dallas, USA
 
Join Date: Feb 2004
Posts: 3,953
It's not your codecs, it's your computer system color settings
__________________
The Z-Axis
 
Old 11-17-2012, 10:05 AM   #3
starbase1
Veteran
portfolio
Nick Stevens
Capacity Planner
Starbase1
London, United Kingdom
 
Join Date: May 2005
Posts: 39
Quote:
Originally Posted by darthviper107
It's not your codecs, it's your computer system color settings


So why would the settings affect a black video display and not a black still image display?

And where are these settings so I can change them? (On Windows 7)

Thanks for the pointer!
Nick
 
Old 11-17-2012, 11:55 AM   #4
imashination
Expert
 
imashination's Avatar
portfolio
Matthew ONeill
3D Fluff
United Kingdom
 
Join Date: May 2002
Posts: 8,940
If it is your display settings, computers use special overlay layers for video playback, these will have their own gamma, brightness and colour settings. Check your nvidia/ati control panel.
__________________
Matthew O'Neill
www.3dfluff.com
 
Old 11-17-2012, 02:19 PM   #5
starbase1
Veteran
portfolio
Nick Stevens
Capacity Planner
Starbase1
London, United Kingdom
 
Join Date: May 2005
Posts: 39
Quote:
Originally Posted by imashination
If it is your display settings, computers use special overlay layers for video playback, these will have their own gamma, brightness and colour settings. Check your nvidia/ati control panel.


OK, I'll give it a look.

I still don't understand though - if its a global display setting, how come codecs like the Sony UV one deliver completely black blacks when other codecs do not?

I really saw that as conclusive that it must be the codec.

I'm not saying your wrong, just that I don't understand!
 
Old 11-17-2012, 02:40 PM   #6
imashination
Expert
 
imashination's Avatar
portfolio
Matthew ONeill
3D Fluff
United Kingdom
 
Join Date: May 2002
Posts: 8,940
im not saying it is the overlay settings, but consider different media players will use various combinations of direct draw, directx, opengl and such to display content. I notice youre using mplayer classic and vlc, its possible vlc skips the use of an overlay.

Or its entirely possible that every codec is screwing up your blacks ;-)
__________________
Matthew O'Neill
www.3dfluff.com
 
Old 11-17-2012, 02:50 PM   #7
DePaint
Banned
 
DePaint's Avatar
portfolio
Emre M.
Istanbul, Turkey
 
Join Date: Jun 2008
Posts: 1,156
Try the Lagarith lossless CODEC:

http://lags.leetcode.net/codec.html

If you still have problems with black when using it, this is a Gamma issue in your display driver/Windows display settings.

For example, my Samsung laptop switches on something called "Movie Colour" when you open a video player.

You need to go into the setup of your graphics settings, find the option that changes colors when playing video, and disable it.

Here's the good part: Just because your computer screws up the Gamma when playing a video file doesn't mean that other people's computers will do the same.

So what doesn't look "pure black" on your video player may very well look "pure black" when you give the video to someone else...

Do you have a 2nd PC you can try this on?
 
Old 11-17-2012, 02:52 PM   #8
starbase1
Veteran
portfolio
Nick Stevens
Capacity Planner
Starbase1
London, United Kingdom
 
Join Date: May 2005
Posts: 39
By George I think he's got it!

That did it - I told the NVidia to take over video settings, dropped brightness 5% and I now have deep rich blacks!

Thanks to responders, that one has been bugging me for ages! I guess lossless ones must over ride the settings or something.

Nick
 
Old 11-17-2012, 02:56 PM   #9
starbase1
Veteran
portfolio
Nick Stevens
Capacity Planner
Starbase1
London, United Kingdom
 
Join Date: May 2005
Posts: 39
In case anyone else hits this, I attach a screen grab showing the exact nvidia panel I adjested to fix the problem.

Thanks again for the help,
Nick
Attached Images
File Type: jpg video-settings.jpg (45.7 KB, 37 views)
 
Old 11-17-2012, 03:26 PM   #10
DePaint
Banned
 
DePaint's Avatar
portfolio
Emre M.
Istanbul, Turkey
 
Join Date: Jun 2008
Posts: 1,156
Quote:
Originally Posted by starbase1
That did it - I told the NVidia to take over video settings, dropped brightness 5% and I now have deep rich blacks!


You should be aware that this -5% setting only affects YOUR system.

When you give your video to others, to view on their PCs, your -5% drop in luminance won't appear.
 
Old 11-18-2012, 06:07 AM   #11
teruchan
Skeleton Man
 
teruchan's Avatar
portfolio
Terrence Walker
The Last King
of Scotland
Shanghai, China
 
Join Date: Jan 2003
Posts: 893
Oh the jokes that could be made on this title.
__________________
Terrence Walker
Studio ArtFX
Learn How to Make Your Own Animated Projects!
You don't need millions of dollars or major studio backing!!
 
Old 11-18-2012, 08:09 AM   #12
jburford
Expert
portfolio
Jeffrey Burford
_
Frankfurt, DE
 
Join Date: Nov 2005
Posts: 232
Grin, just watch Iron Sky!
 
Old 11-18-2012, 08:09 AM   #13
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,480
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:16 PM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.