Mental Ray - Render Troubleshooting

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

REPLY TO THREAD
 
Thread Tools Search this Thread Display Modes
  04 April 2006
Relationship between Mental Ray and System Units?

Hello Everyone

Well didnt know about this thread about mental ray troubleshooting existed.. didnt notice it!!

Well so rather than posting twice the same question here is the link to the thread Click Here

Cheers
__________________
I am not afraid of Tomorrow
For I have seen Yesterday
And I love Today

My Blog
 
  05 May 2006
Angry STOP at 99,7%

Hi,

I am rendering an image in the "Mental ray" of the Max 7.0 and I am using only the Final Gather without GI, and every time that I place for render, the calculation of FG stops at 99,7% and it joins the MAX, and doesn't appear any error message. I just get render, turning off the FG.

Thanks Christiano
 
  06 June 2006
I started getting the black splotches on frames of an animation and so far I have been able to get rid of all of them by increasing the Final Gather Samples.

I have another animation rendering that is just photon mapped with no FG. It's getting small black pixels sometimes. I'm trying to get rid of them by similar means, but I'm still experimenting so no definative answer on non FG renders.
 
  06 June 2006
Any suggestions?

Hi,

If anybody can help with this problem it would be great. I'm rendering fur with Mental Ray in Max 8. However, when I render it on the render farm, the fur gets detatched from my character and is left behind!! No motion blur enabled either. Any suggestions here will be greatly appreciated, it is driving me crazy at this stage.

Looking forward to your help

Paul
 
  07 July 2006
hi everyone;
im having 2 problems on mental ray;
first of it is about the maps, as you can see at the image my texture is being blurry when it goes away from camera....

And the second one is about .rpf files. sometimes my renders stopping without any error it doesnt close but cannot finish the render

thanks for your helps...
__________________
Eren Saritas
Animation TD
 
  07 July 2006
For the texture, you need to use an elliptical filter, i dont know how this is implemented inside max, but check elliptical filter with the help docs.
__________________


Bucket Watcher
 
  07 July 2006
Network render error messages

Hello and thanks for a spendid thread.

I have the following problem; i have set up 3 machines with complete install of 3dmax 8. I am using one as master and the other two as satelites to speed up rendering. All machines running XP.

I set up my benchmark scene, and i follow the instructions about using the hilbert bucket and only sending geometry when needed.

I set up hosts and ports, and I use only my local machine for shaders and maps, so that I do not have to rely on shaders and map files on the satelite machines.

However;

I get the following error messages when using the distibuted bucket rendering:

LINK23.n error 191029: failed to link library on host Satelite1

The picture renders ok, and i can read from the progress bar that MR actually appears to be using the satelite machines for rendering - but I can't measure any acceleration in the rendering (it takes the same amount of time using 2 satelites as when i am rendering on my local machine).

Any help or tips highly appreciated, even the most newbie tips, - I believe I've read most of the threads, without luck,

FAB

Last edited by Fab7000 : 07 July 2006 at 06:05 PM.
 
  07 July 2006
I've noticed that distributed bucket rendering for a single image doesn't seem to save that much time. Unfortunately I can't really give you any concrete help since I never really got it to work faster (I think in my case that it had something to do with the way the different slaves needed to access the maps required and the performance of the various slaves).

Anyway, the easiest way to know if your render is using the extra cpus is to see how many buckets are being rendered. In my case I had 12 buckets rendering at the same time, quite a sight Problem was that sometimes buckets would get stuck on some areas of the image for a ridiculously long time and thus nullifying the gain from having slaves...

Sorry for lack of help

Originally Posted by erensaritas: hi everyone;
im having 2 problems on mental ray;
first of it is about the maps, as you can see at the image my texture is being blurry when it goes away from camera....


Try setting your Bitmap Filtering to Summed Area instead of Pyramidal and reducing the Blur to 0 (or whatever is closest, right click the spinner next to the Blur value). That should sharpen it a little at least. No idea why the rpf files break mr though...
__________________
Peter
_______
Environment artist blog - iPhone 2D Shmup Ultrablast!

Last edited by urgaffel : 07 July 2006 at 05:37 PM.
 
  07 July 2006
Distributed bucket rendering experiences

Thanks for the reply Urgaffel.

I've investigated a bit furter and found the following observations I would like to share.

First of all, Autodesk states that the distributed bucket rendering is ideal for quick previews of single renderings, according to this article: http://www.virtualpartners.com/PDFf...d_mentalray.pdf


However, setting up a DBR renderfarm with only 2 or 3 satellites, like I did, give almost no gain in images that takes less that one minute on your local machine. The network communication eats up all the upside of using the distributed satellites.

However, if you add extra satellites, preferably all 8, and if you are rendering images that take from 5-6 minutes to 5-6 hours, you will really feel the difference.

I've experienced that the acceleration is non-linear, almost logarithmic, as a render that takes about 8 hours on my local machine took only 17 minutes when hooked up with 6 satelittes.

However - ALL errormessages in the Mental message window will seriously slow down your render. F.ex. I recieved an error that a certain library could not be found on the satellite machines. After a few reboots the error stopped appearing, and the render time went way down.

Likewise, if f.ex. a HDRI is in a wrong colourformat and thus i handled as a RAW image, the rendertime explodes.

And images render quicker if you distribute the maps and shaders to the individual satellites.

So my advice is; get rid of all errors in the MR prompt, distribute the textures, if you are using bitmap based textures, that is, install more than a few satellites and use it for renders that takes +10 minutes.

Any other advice is appreciated - for instance on how to install the satellite on a new system without having to install an entire 3dMax8.

FAB
 
  07 July 2006
Hi everybody, thanks for making this post
I've been having this problem for a while now and it's completly stopping me from getting this project any further.

Here is an image to show my problem:


render is in 3ds max/mental ray
left image has no Final Gather while right image has Final gather
as you noticed, the eyes becomes very self illuminated with final gather and i cant figured out why... thank anyone who can help me!

mostly i used the settings from the tutorial with globulous ( http://www.lamrug.org/resources/doc...in-tutorial.pdf )

i used different scatter group for the face and the eyes (the tutorial says to use the same but if i do it REALLY gives bad results, eyes become even more white and uglier)
 
  10 October 2006
Arrow

Hey guys,

I'm having this big problem with Mental Ray, every bucket just stays there without showing what it just renders. The silly thing about it is that it takes as much time as it would if it was looking fine.

Render size 2000, 3000 or 4000 square px.
No FG
Lots of lights using MR Light Shader
...


Thanks.
Attached Images
File Type: jpg render_artifacts.JPG (32.3 KB, 69 views)
__________________
www.albertfeliu.com
 
  10 October 2006
If you are using distributed bucket rendering I've noticed that sometimes buckets take ages to render that should take no time at all... What happens if you render it locally (just rendering on one computer)?
__________________
Peter
_______
Environment artist blog - iPhone 2D Shmup Ultrablast!
 
  10 October 2006
square patches?

we are using the mr_prime script to set up mental ray, i also turned off rebuild for the photon map and the FG. Then I turned on depth of field with a 200unit distance.
after changing the settings i changed our renders started getting wierd squares with random shadows in them(see attatched). Can anyone help us out with this?
Attached Images
File Type: jpg T0000.jpg (68.8 KB, 223 views)
 
  10 October 2006
re: square patches

that looks like you have your FG set to "Preview (no precalculations)"
__________________
-cliff
www.LeapOffaCliff.com
 
  10 October 2006
more issues`

Thanks for, that thats exactly what it was.

after solving that we are getting renders we can work with, however our shadows seem to be shaking violently has anyone seen this before, and have an idea how to fix it?
I have fg set at 250 with a radius of 350 and GI set at 1000 photons. We are using backburner to net render the images then compiling them with ram player in max.

here is a link to my video on youtube, you can really see the shadows shaking in the street.

http://www.youtube.com/watch?v=pymhiHL_93Q

o0n second thought you can only kind of tell the shadows in the street are shaking because of youtubes quality :/
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:32 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.