RayFire Tool

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Display Modes
  02 February 2014
How to run a second sim on a scene

Hey there,

I have a scene where I have collapsed walls of a building. I have reduced the frames so frame 0 is the frame with all the building collapsed and debris. Now I want to run a sim on the scene where the room falls in on the building, already simm'd.

I have attached all the rayfire selections from the first sim together, but I am not sure how to start fresh with Rayfire to start a new sim. I have cleared all the boxes and added my new elements, but when I go to manager and select the pieces I get all the original pieces, if I delete the fist sim is deleted also.

How do I keep the results of a sim in place but be able to use Rayfire again in the same scene?

Cheers

S.
 
  02 February 2014
ok just to answer my own thread, I found it.

In case anyone else was stuck with this, under Tools -> Clean up scene....
 
  02 February 2014
Have anyone used rayfire with "birth group" particles from pFlow, i thought it would be a nice way to get a fragmented geometry and trigger it with particles and send it to rayfire. But a soon as i try to simulate i get an error message saying:
"-- Unknown property: "getMaterial" in $Birth_Group"
Does this mean rayfire cant recieve objects from pFlow if they are used with that birth type or am i doing something wrong?
Using max 2014 x64 and rayfire 1.62.04
 
  03 March 2014
Rayfire 1.63 and Max 2014 SP4 crash

Is anyone else experiencing this problem since updating Max 2014 to SP4 and Rayfire to 1.63 : Now every time I try to load any scene created with an older version of Rayfire, Max crashes to CER. Mainly, the scenes had MassFX Rigid Body Modifiers created by RF, but perhaps there is another RF plugin node or custom attribute that crashes Max.

I updated from RF 1.62 and SP3 within the same couple of days, so I do not know if SP4 broke Rayfire or RF isn't working right with SP4.

[EDIT] It could also be an updated NVidia video driver too. There is a thread on the Area as well.

[ANOTHER EDIT] I'm thinking it is RayFire Fragmenter Modifier at this point. That seems to be the common thread in the problem I'm noticing.

[UPDATE] After various experiments and some feedback from Mir, I now feel like this is more of a SP4 issue than RF.
__________________
Shawn Olson
Autodesk Expert Elite
3ds Max Charter Member

Developer of:
Wall Worm Tools
CorVex Level Design Plugin

Last edited by wallworm : 03 March 2014 at 06:59 PM. Reason: Further clarification
 
  03 March 2014
Mesh exploding as soon as bake starts

Hey all,

As soon as I click 'Bake' all my fragments turn (per the image). Has anyone seen this mess before? What should I look at to fix this? I haven't had this happen before and not sure what to do.

Thanks all.
Attached Images
File Type: jpg RayfireMess.jpg (77.2 KB, 22 views)
 
  03 March 2014
Sorry to be a pain in the butt with this.. but I am really stuck and cannot proceed with what I am doing until I sort this out.

I have tried a reset xform on the pieces and that just ruined the whole object.

Any ideas on what I have mucked up with this one?
 
  03 March 2014
1. make sure your object is above zero Z plane or turn home grid as ground off,
2. decrease coll tolerance to 0
3. make sure u dont have any forces in sim prop and sim again,
4. play with time scale - maybe when the sim is slower u might find whats happenings

thats all that i can think of, but never had that problem
 
  03 March 2014
ah good work dude, I slapped it just about 0 on the Z plane and reduced the col tolerance and bingo, I have a statue that does what it should during the bake.

Thanks heaps

S.
 
  03 March 2014
A question about the Asperity Promo vid

So this is one of those post it and hope attempts, but here goes anyway.

There is a promo for the awesome Asperity addition to Rayfire

https://www.youtube.com/watch?v=G_L...mzU_inIMmIwxXKg

At 1:10 in the video there is a really really cool looking 2012 type ground collapse. I was wondering if anyone had any sort of workflow ideas about this. I have tried this sort of thing in the past. Using a large chuck of mesh, fragmenting it and then freezing the outer parts of it then triggering the fragments to collapse. My issue has always been not been able to get those long looking fragments, mine are always stone like. I have tried variants to clusters but haven't been able to achieve it. Here it is in that promo and I would LOVE to understand how it was fragmented.

Cheers
 
  03 March 2014
oh and additionally I get this random issue again where my collision objects adopt a feather like material.

See attached, as soon as the sphere comes in contact with them they belt off in all directions.

This really does derail me and I don't know what it happens. I have done everything per previous suggestions and seem like I have done the same as other times but for whatever reason this time it all goes pearshaped.

The attached zip is a basic file. (max 2012 RF1.63) It has a plane and a cube fractured. Simple sim, press bake and the pieces should fall.. they just detonate in the air. Can anyone see what is up with this.

help
Attached Files
File Type: zip rayfireIssue.zip (69.7 KB, 8 views)

Last edited by Mafx : 03 March 2014 at 07:28 AM. Reason: added scene
 
  04 April 2014
its great tool i love thus plugin
 
  05 May 2014
Anyone having problems with static objects not being static with Rayfire 1.63 on Max 2012? I've got version 2.84 of the PhysX SDK installed and 2.70.1028.1400 of the PhysX plugin installed. The same versions as I used to use with Rayfire 1.58 I think.

I can't upgrade to a newer PhysX plugin because installing it makes max files incompatible with any other users, even when PhysX isn't used.

It seems to be ok if I use Max 2014, but we're still on 2012 at work for now.

Is there an official Rayfire forum these days? I can't find one, but there used to be one.

Thanks
 
  07 July 2014
RF 1.64 Voronoi Modifier is very fast and promising... but I'm experiencing a lot of unexpected results.

Many fragments are invalid. Sometimes a fragment will overlap many other fragments and/or it will have missing polygons from sides. You can see these problems most when you give a Gap value in the scaling group of parameters.

Attached is an example.

Such invalid fragments seem to also increase the odds of larger than expected fragments getting deleted when using the Delete < # .
Attached Images
File Type: jpg rf-1.64-rf_voroni_gap_error.jpg (91.5 KB, 18 views)
__________________
Shawn Olson
Autodesk Expert Elite
3ds Max Charter Member

Developer of:
Wall Worm Tools
CorVex Level Design Plugin
 
  07 July 2014
Originally Posted by wallworm: RF 1.64 Voronoi Modifier is very fast and promising... but I'm experiencing a lot of unexpected results.

Many fragments are invalid. Sometimes a fragment will overlap many other fragments and/or it will have missing polygons from sides. You can see these problems most when you give a Gap value in the scaling group of parameters.

Attached is an example.

Such invalid fragments seem to also increase the odds of larger than expected fragments getting deleted when using the Delete < # .


Hi, yeah, we already kno about this problem and will fix it in next release.
Sorry for troubles, this is first release of Voronoi modifier and even tho we tested it in some cases it still may fail.
If you or someone else get weird results or found some bugs, please email about this to me with attached objects or scenes, everything will be fixed.
__________________
www.RayFireStudios.com
 
  08 August 2014
@wallworm: Not sure whether you have the same problem but your attached file looks like the problem I have. Whenever I fragment an object before running a simulation I will get cracks and gaps at time 0. So there is no way for me to rewind my video and start it with my object fully intact. It will always be partially or sometimes even the total object damaged.

However, if I don't fragment it and use the object's mass and the kinetic energy from fall to break it I can rewind the video and start of with a normal object.

The problem is that I have to fragment it in order to use forces.


So to summ it up:

I take like a ball and move it on the z-Axis. I add it as an kinetic object as let's say glass.
I add a plane as floor and make it the static object. Then I fragment it and hit "bake".
It's going to fall apart. After the simulation is over so time = 100 I take the time slider and
pull it back to 0 but I don't end up there with my ball but with an already cracked sphere where you can see all the cracks and gaps and parts are already falling. It's like the simulation started somewhere on a negative Timeline.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 08:08 AM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.