PGroup -> Link List

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 09 September 2012   #1
PGroup -> Link List

Hello,

I am wondering if someone knows of a way to get a particle group to link list field with xpresso?

the link list in question is Tracers "Trace Link"

thanks
__________________
Twitter | Ratata
 
Old 09 September 2012   #2
Maybe tell us more on what you want to do? I don't understand the idea behind this.

Also, i moved this to the apropriate subforum
__________________
- www.bonkers.de -
The views expressed on this post are my personal opinions and do not represent the views of my employer.
 
Old 09 September 2012   #3
basically I want to use an user data link field, with PGroup in it, and link it to tracers trace link field,

the idea is to make a setup that can be copied and simply adjusted via user data fields, so there is a stremline workflow of just draging stuff into the fields.
__________________
Twitter | Ratata
 
Old 09 September 2012   #4
You mean something like this?
Attached Files
File Type: zip trace_link.zip (57.1 KB, 16 views)
 
Old 09 September 2012   #5
Exactly, I tried this also, but I can't drag the particle group from the "TP settings" in in/exclude field no matter what, how exactly did you add the group?

thanks!
__________________
Twitter | Ratata
 
Old 09 September 2012   #6
I copied user data interface from the tracer object. Draged TP group from TPSetings to my user data. Thats all
 
Old 09 September 2012   #7
now thats some trickery =)

thanks alot!
btw is that even documented? or a fluke? since user data manager shows no diference between tracers link field and ordinary link field...
__________________
Twitter | Ratata
 
Old 09 September 2012   #8
No idea. I got similar issue with in/exclude... I guess it's something with referencing specific object.
 
Old 09 September 2012   #9
Interesting.

Now, to add some confusion :
On my Tracer's Trace Link Parameter in R13 I get the "Copy User Data Interface" option in the right click-menu, just as I would expect it to.
That option doesn't show in my R14 though !

I know the rightclick menu was reorganized with this release and User Interface now has its own SubMenu, but for some reason it doesn't show up with the Trace Link Parameter.

That makes this trick impossible to do in R14 !

Is there a reason for this ?
It does confirm there's something "special and specific" about the Trace Link Field.
Who can get to the bottom of this ?
 
Old 09 September 2012   #10
strange thing is:
the tracer linkfield is a user-data entry of type "in/exclusion".
when i try to add my own user-data of type "in/exclusion" i can´t dragndrop TP-groups in it.
but with "copy/paste user data interface" it works well.
a feature? a bug? user-error?
any knowledge here? maybe Björn?

fuat
 
Old 09 September 2012   #11
I can copy the user data settings of the trace link field in R14 without problems.

The list can be modified for special purposes if a developer creates an own interface. The variations are numerous. By default the link list in Xpresso only supports the most common types. If you copy the user data setting sof an existing object property in the AM you also copy all settings and restrictions that come with it, thats why the lists can behave differently.
__________________
- www.bonkers.de -
The views expressed on this post are my personal opinions and do not represent the views of my employer.
 
Old 09 September 2012   #12
Originally Posted by Srek: The list can be modified for special purposes if a developer creates an own interface. The variations are numerous. By default the link list in Xpresso only supports the most common types. If you copy the user data setting sof an existing object property in the AM you also copy all settings and restrictions that come with it, thats why the lists can behave differently.


ah ok, didnt know that. thanks for the explanation.

yes, i can copy/paste in R14 without problems here, too.
 
Old 09 September 2012   #13
Björn,
I understand what you're saying, yet I'm still confused.

Let's keep it simple and concrete, I'll stick to the example of the initial post :
I have a "Tracer Object". I want to copy its "Trace Link Field" to use it somewhere else as a User Data.

So I expect to right-click on the "Trace Link Field" and be able to select "Copy User Data Interface".
I could do that in R13, but not in R14.

How can / should I do this in R14 ?

see the illustration :
- on the left side it shows how to "Copy User Data Interface" in R13
- in the middle it shows what I see in R14
- on the right side I photoshopped what I would expect to see in R14

d

 
Old 09 September 2012   #14
Never mind.
Service Update r14.025 just got out,
and it's fixed now


d
 
Old 09 September 2012   #15
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:11 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.