Topology Brush help needed..

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  06 June 2005
Topology Brush help needed..

I have had a look at the topology brush, and it looks like a powerful feature, but i'm not sure exactly how to use it.. Anyone used this tool yet?
 
  06 June 2005
Same here... a brief description of what do do after drawing the lines on would be very cool... the video isn't all that clear.
 
  06 June 2005
After drawing the lines, press enter to generate your new mesh
 
  06 June 2005
I followed all the steps up to pressing enter. I generated the new mesh, but is this a way to combine the new mesh with the old? I guess im confused because what i was thinking is that if i have a mesh say of a human face then i can basically draw new geometry to change the flow of the existing mesh.. Damn i just confused myself more..I think the video demonstration should go into a bit more depth as to what you can accomplish using this tool. Thanks for the reply
 
  06 June 2005
well after you create the new mesh you can delete the faces on the original mesh and weld vertices. I don't think there's a way to actually draw a topology change on the original mesh. I think you can only draw out your mesh, create it, and then connect it to your original mesh.

someone please say i'm wrong.
 
  06 June 2005
yeah, it creates a new object everytime, at least with all my experimentations, and i've had it for half a year If you look in the video, the topology brush and snapping one, it shows how they remade the model from scratch, which shows conencting the differting object to each other, not to the original model

So basically yeah, new object Hope that helps
 
  06 June 2005
Hi there,

You should see this functionality added to the topology brush in the near future. (We were initially hoping to get it into 1.4.) When it is, it will mainly be an automation of a process you can now do yourself with several steps, as lovisx suggested. Stay tuned!
 
  06 June 2005
i would advise going through this whole thread (with all the links in it). there is some major info on the tool. (this was a thread started in silo v1.3, and the topoBrush did not work as well then. the algorithm was improved (and automated) since)

http://www.silo3d.com/forum/viewtopic.php?t=2277
 
  06 June 2005
Originally Posted by Cinnsealach: After drawing the lines, press enter to generate your new mesh


 
  06 June 2005
In a nut shell...

Load a high res model.

Call TOPOLOGY BRUSH from the drop-down.

Draw your new topology over the model.

(Shift to continue a line, CTRL to end one...see the SILO help file for other hints.)

Hit enter to generate new object based on your new topology but following the surface of the high res mesh.



Hope this helps...

s o u t h e r n
__________________
SouthernGFX Website
http://www.southerngfx.co.uk
Twitter
http://twitter.com/southerngfx
 
  06 June 2005
how do i rotate the view when using the topology brush? my rotate is assigned to RMB. i also cant pan.( ctrl+RMB) but i can zoom(shift+right)

EDIT: i tried assigning rotate to shift+RMB and zoom to RMB, now i can rotate fine but i can't zoom..
__________________
have a nice day :-)

Last edited by ares623 : 06 June 2005 at 01:15 PM.
 
  06 June 2005
It should rotate as normal - alt+whatever mouse button (right in my case, can't recall if that's default or not).

My setup is

alt+lmb = pan
alt+mmb = zoom
alt+rmb = rotate

Actually, I think I swapped zoom and rotate from default assignment to match XSI.
 
  06 June 2005
hmm... it seems that RMB is used to close loop when in topo brush mode. maybe that's why i can't rotate. but why can't i pan(ctrl+RMB)?
i really don't want to change my mouse setup.. i assinged alt+RMB to MSM and now i am comfortable with it. my best choice now would be just to make a different mouse setup for topology brush mode and just switch between the two..
__________________
have a nice day :-)
 
  06 June 2005
Probelm with mesh display

hi,

i am having a problem in that the new mesh generated by the topology brush is not appearing on top of the tracing object as it does in Glen's screengrab and the tutorial video on the nevercentre website.
Can someone tell me what I am doing wrong?
many thanks

marll
 
  06 June 2005
Hi Marll,

It won't appear ontop/infront off, it will appear as if it is embedded. In the image above I've moved the new mesh forward in the Z axix a small amount so you can see it. The new topology is created in the same 3D space as the high res model. Simply select the high or low poly object and move it out of the way or delete as needed.

s o u t h e r n
__________________
SouthernGFX Website
http://www.southerngfx.co.uk
Twitter
http://twitter.com/southerngfx
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:58 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.