View Full Version : motion vectors

08 August 2011, 10:12 AM
Hi all, I have a motion vector pass problem in Mental Ray.

It works all fine for objects with just some keyframes on them. When the object stops moving, the motion vectors disappear (the image goes to black). Exactly as I'd expect.

But as soon as I do this with an object which has skin bound to it's bones, it gives me a problem. When the object has stopped moving, the motion vectors are still there. They just don't disappear like I'd expect.

I've checked this in both the 2012 x64 and 2011 x64 version. With multiple objects. It only happens when I bind skin to bones.

I'm not sure if this is supposed to happen, or why. Maybe I'm missing something important.

Can anyone help me? Because now my objects have motion blur (in post), even when they aren't moving anymore.


08 August 2011, 01:34 PM
Haven't tested motion vector on bound object! Whats your animation look like? Did u try 2d motion vector or remap? Any screen snap might better!

08 August 2011, 12:44 PM
It's the same problem for both the 2d motion vector and the remap pass.

I've included a screen shot of the animation. This isn't my animation of the shot i'm working on, but it illustrates the same problem.

The sphere and the cube on the left and right have correctly working motion vectors on them. They just move op and down to 'prove' that the vectors actually work as they should.
The cylinder is bound to the bones. And gives the problem.

I've also included frames 4 and 6 of the motion vector pass. The objects come to a rest at frame 4. Frame 4 is correct but frame 6 (and 5) should be entirely black. No motion vectors. As there is.. no motion.

08 August 2011, 12:47 PM
And here the maya 2012 x64 scene file if you'd wish to have it and a vector blur pass (done in Nuke).

08 August 2011, 05:26 AM
And here the maya 2012 x64 scene file if you'd wish to have it and a vector blur pass (done in Nuke).

I've tested your scene and found that if u dont bind the object, just simple key the object,the vector pass works fine! And i've tried rebind the cylinder,still not work,Weird!

But i dont have this problem on my character with the vector pass!

CGTalk Moderation
08 August 2011, 05:26 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.