View Full Version : simple PlanarMapping in Maya?

07 July 2011, 12:08 PM
I have an Illustrator file which I imported to maya. Then under Surface I went to "Surface->Planar" to make it a plane. And now I just want so place an image on it as a layered shader, but HOW can I move my Texture after applying??? :sad:
I cannot go to Polygons and "Create UVs->Planar Mapping" because then it will tell me, that this only works on polygonal objects. It also doesn't work with the Texturing under SubDivs, cause my created plane isn't a SubDiv either.
So I figured, maybe I need to convert it first, but as SubDiv my Shape is pretty messed up and as Polygons I don't get the roundness detail that I want.
Well... I also don't get the roundness that I want with the shape that is created (the path is smooth but the rendered shape is quite angular...), if someone has an answer for that as well, that would be great, but my main problem is, that I cannot move my texture on my "planarTrimmedSurface".
I am quite new to Maya and I did tutorials over tutorials about UV mapping and modeling etc. but I cannot find an answer anywhere! How stupid or blind am I?!?! :cry:

Any help would be really great!

Thanks so much in advance.

PS: I am working with Maya 2012.

07 July 2011, 09:14 PM
The planar surface you created from the Illustrator curves is NURBS geometry. One way to texture it is to create a 2D texture projection in the Hypershade.

In Maya 2012 to create a projection node in the Hypershade right click over the 2D texture (such as File or PSD File) in the create bar and select "Create as projection".

In the projection node you will probably want to use the Planar projection type.

To move your texture projection around on the surface you can translate the place3dtexture node (that is connected to your projection node) around in the Maya scene using the move and rotate tools. The Fit to Group BBox button in the place3dtexture node is handy to scale the size of the projection.

You can also adjust the place3dtexture node as well to rotate adjust the 2d texture settings.

Make sure to group / parent the placement node with the surface if your are animating the surface.

07 July 2011, 05:31 AM
Thank you so much!
That was exactly what I needed! =)

07 July 2011, 07:06 AM
Thank you so much!
That was exactly what I needed! =)

07 July 2011, 09:01 AM
Oh, and I just found a solution to the problem that my edges of my "plane" weren't smooth.

So, when I have my "plane" selected I go in the Attributes Editor to "Tessellation" and there under "Common Tesselation Options" I check "Smooth Edge" and drag the slider all the way to the right (0.999). And now my edge is reallyreally smooth :)

CGTalk Moderation
07 July 2011, 09:01 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.