View Full Version : Issue with viewport capture

07 July 2011, 07:11 AM
I know this is a common issue with my fellow XSI users, but I've yet to see a solution.

When capturing an animation sequence, sometimes the capture would start but closes right away. Quicktime player would pop up, but only with a black single frame. Restarting XSI would solve the probelm, but after several captures, or after leaving the computer idle for a while, the probelm reappears.

I've seen this issue since i've been using XSI (since version 4.5) until softimage 2011, but no solution yet! :banghead:

This problems occurs with any scene, any type of video format or codec and several different systems.

Any one here know of any solutions?


07 July 2011, 03:39 PM
Dont want to state the obvious, but did you check the sequence settings in the "Capture Viewport" panel?
If settings are fine i guess its something related to the graphic card, do you have an ATI card? Tried changin drivers?

Ran out of ideas sorry!

07 July 2011, 08:29 PM
I get the same thing sometimes on several computers, all using Nvidia graphic cards.

07 July 2011, 02:00 AM
Yes, the sequence settings are fine.

I've used nvidia cards before, now im using Ati, all with latest drivers. Problem exists no matter what :banghead:

I'm thinking its not to do with the system, as this happens in so many different people and machines. (I actually think almost every XSI user has experienced this) Must be some fundamental issue with Softimage?

As an animator that uses capture frequently its really annoying to restart everytime this problems occurs.

Please let there be a solution!

07 July 2011, 02:57 AM
It is possible it's a fundamental issue with XSI, but as someone who's never had it unexplained, I would be more inclined to put it down to a combination of factors.

Nine times out of ten it's a system related file lock, or an overzealous process lock.
A simple test to see if it's the case is, when it happens, to run on a different (and local) file path.
Another is to see if it still happens in admin/root privileges.

I have seen it before (very rarely), but never unexplained. A simple file writing operation isn't black magic, if it's interferred with, it's usually easily explained, and most often tied to network, permission or addressing issues.
Soft might or might not be overzealous or weak in some processes (no more than any other software to my knowledge though) when handling those filepaths, but the root cause of the trigger is usually not just a randomly generated number somewhere interfering with your filewriting once in a while :)

It's also a good deal more frequent on windows than it is on linux, and considering of the two the one with entirely too many interim steps and wrapping going on is the latter, it tells a long story about the OS ;)

07 July 2011, 08:26 AM
I've tried changing paths with no luck. Also I am running as admin.

I dont understand what you mean by it could be a file/process lock. Too technical for me!

07 July 2011, 05:40 PM
Usually when its a file lock, XSI will give you an error saying it can't access the file, etc. I've found that if you know it isn't open in some other location (or a privileges issue), try writing it somewhere else, and copy and pasting it over the desired location, and this sometimes frees up the lock.

Although it happens a lot where there is no error, and the preview just quits instantly. This happens a lot here and other places I've worked & used XSI (All Windows and NVidia). Restarting XSI is a sure fix to the problem. Annoying when your scenes take 5-10 minutes to open on heavier shots.

I don't disbelieve people when they say it has never happened to them, but it does amaze me because of how common it is in my own experience.

08 August 2011, 09:19 AM
seems to be happening more often in the latest versions. It is solved with a restart of SI, which suggest a filelock or memory issue.


CGTalk Moderation
08 August 2011, 09:19 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.