View Full Version : Wom_archlight = Noise reflection?

07 July 2011, 05:02 PM
Hello everyone.. Im having a problem here with wom_archlight...
When I try to render it, with the arealight not visible, its ok. When I turn on the visibility for the MentalRay arealight, the result is a noisier reflection on the object. I would need a loooot of samples to handle this?

- The material is a glossy material with 128 samples.

- The light is Arealight with Wom_archlight shader on it. The Mentalray area light is set to rectangle, visible, and the raytraced shadows is with 128 samples.

I made a lot of tests, with different shaders too, and I dont know why this happens.. The only difference between the images below, is the shader atatched to the light and the Cm2 factor.

Wom_archlight + Area light visible:

Wom_archlight + Area Light not visible:

Portal Light + Area Light visible:

Mia_photometric_Light + Area Light visible:

*Physical Light OR Mib Light photometric + Area Light visible:

Ok, for this last one, the result was very similar, so I thought about posting only one image. AND, I dont know how to deal with these shaders yet...

I dont know why Wom archlight give me this NOISE in the reflection, and I tried everything (I think). The noisier reflection on the other shaders, I think I can handle with the samples, or turning on unified sampling etc..

I thought about putting a reflector maybe using lightsurface, and turning off the visibility of the AreaLight... but I dont know how it works, so I didnt test it yet.

But the real reason of this post at all, is that im trying to figure out the best workflow with photometric lights in maya.. Like in MAX. In max we have the photometric light in there so its easy to use. But in Maya I want to know how to configure a light like that to work with it. :banghead:

Thats it.. can someone give me a little help here? :)

07 July 2011, 10:48 PM
You need to raise the samples on the Area Light. Depending on the kind of area light you use though. This will increase the sample for the primary and secondary reflections.

If you seperate this into passes, you will see all of the noise is in the specular pass, and the reflection is clean.

The work around for improving rendertimes, is to turn off specular in the light, then use reflectors to fake the specular in the reflection pass. It will render fast and noise free and you still get your nice area light diffuse/shadow

07 July 2011, 02:42 AM
Yeah, I know that i have to raise the samples, but even with 128 that was the result.. with 128 in max I have good results.. thats why i was asking..
How is the workflow with reflectors? Like.. I have to made them to emmit light? how should I do?
tnks for ur answer

CGTalk Moderation
07 July 2011, 02:42 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.