View Full Version : Architectural render, Mental Ray, huge FG files

07 July 2011, 06:38 AM
So I've got an architectural animation that I'm trying to render. It's 700 frames, I've attached the first frame and it cranes in and around the building. The trees and cars are mental ray proxies and I'm trying to use final gather.

My problem is that if I render every 10th frame for the final gather pass, the file gets very big, over 100GB. Even if the file is relatively small, a few hundred MB say, the batch render just hangs or crashes (even though the RAM doesn't appear to fill up).

For the final gather pass, I've got these settings:

Quality 100
Interpolation 20
Rebuild off

For the actual render I have rebuild set to Freeze.

Anyone have any ideas on what could be giving me issues?

07 July 2011, 07:19 AM
You can try on "Finalgather legacy" option.

07 July 2011, 07:40 AM
Are you talking about the changing the Final Gather Mode? I can't find anything called 'Finalgather legacy'.

07 July 2011, 01:14 PM
Are you talking about the changing the Final Gather Mode? I can't find anything called 'Finalgather legacy'.

'Finalgather legacy' this is a hidden property of mr render but you can use it.
just execute this script
miOptionsAddNewStringOpt miDefaultOptions.stringOptions;
setAttr -type "string" miDefaultOptions.stringOptions[30].name "finalgather legacy";
setAttr -type "string" miDefaultOptions.stringOptions[30].value "true";
setAttr -type "string" miDefaultOptions.stringOptions[30].type "boolean";

07 July 2011, 12:59 AM
Ah right thanks for that, what an annoying bug!

07 July 2011, 01:09 PM
You can try on "Finalgather legacy" option.

what does it do?

07 July 2011, 06:50 PM
The new version of Final Gather uses the MAP container to store the data (for a few different reasons). The older version does not.

There was a bug introduced when that change happened that meant appending the file caused it to balloon out of control when using the MAP container.

What version of Maya 2012? I was under the impression that it was fixed in a Hotfix.

02 February 2012, 08:07 PM
I'm trying this to fix a scene which went from 8 minute renders to 2h45m, and I don't know why. When I run the script:

// Error: Cannot find procedure "miOptionsAddNewStringOpt". //

Am I doing something wrong?

02 February 2012, 10:03 AM
did that legacy thing cause that?

02 February 2012, 06:02 PM
That's correct, Duke. I was trying to use the script above to fix some hangups MR was having, but I solved the issue another way (switching from point lights to spherical area lights). I don't know much about MEL; perhaps I was just doing it wrong?

I copy-pasted the script lines above to a .mel file and when running it, Maya tosses back that error. Perhaps there's a more proper way to run a script?

CGTalk Moderation
02 February 2012, 06:02 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.