View Full Version : Rendering large resolution for print with V-Ray for Maya

07 July 2011, 05:50 PM
Hey everybody, HELP EVERYBODY :P

I'm trying to render a 12000*6000 px image to print at 3*1,5m for a presentation poster from V-Ray 1.50 SP1 for Maya 2012.
Up from 8k pix the render crashes.
I'm running a Win 7 64 bit system with a Duo Q9550 (so 4 cores), but only 4 Gig of RAM (about 10 gig of VM). I realize that that isn't a lot memory... I googled around and found some workarounds though, and have been trying them one after the other.

- Proxies... I'm using them for the detailed parts of the model, the rest is either hidden or NURBS (I built the thing in Rhino). Made the viewport faster but still crashes.

- Dynamic memory... 2000 Meg are still crashing. (I suspect I should try again with 3k?)

- Batch-rendering with V-Ray stand-alone... When using the "-reg" tag this helped me render out an 8000k image in 9 hours, which isn't enough but I learned from that that I don't have to set the general quality so high, so I reduced the Adaptive Subdivision treshold a bit as well as the Max Subd and my GI-solutions.

-DR rendering, with my own PC as the only server/client (whatever they call it now). Still crashing. I heard this would be striping the image into smaller buckets, but I guess not when you only have one computer. Is there any way to achieve bucket-rendering with just one PC?
The -reg tag also seems to process everything about the final image except for the actual buckets rendered... this doesn't help as the crash occurs when setting up the render.

I'm using three UV-scaled rectangular lights, a reflection map in the environment and precalculated (at lower resolution) IR and LC for lighting. The thing that is taking the longest was a soft shadow-catcher in a VrayMtlWrapper... tried to bake that also but it took forever, and didn't quite give me what I needed. Now that I know the wrapper a little better it's still the route I wish I would've gone though. Any hints on that? The light-subdivisions are already only at 8.
All that doesn't seem to be too important though, since what overloads the RAM seems to be the resolution alone... Why else would it crash when "initializing the VFB"?! This is the last line in the log, with any method. The VFB is turned off in the file-options by the way.

So I'm this close to just sending it to a render-farm, but I think I'm too tight to pay for the stupid shadow catcher rendering 18 hours... I need it for compositing the thing into a (also huge) photo though.

I'd be thankful for any input at all... I read a lot about all this, but am not very experienced, so beginners hints are also very much appreciated. A step I will take, but not now, is to buy more RAM.

Thanks so much in advance,

03 March 2012, 03:40 PM
Hello... did you get a solution for this? Im running in the same problematic!! Can you tell me how you solved it? Best Regards, Chris

03 March 2012, 04:55 PM
increase the memory even more - I just put it at 8GB. If you have the system RAM, there's no reason not to.

But try rendering in tiles. Since I'm seeing this request a lot, I'm going to make an automatic tile rendering script

03 March 2012, 05:05 PM
Hi, thx for your post.

i got 12 gig of ram and startet tile rendering. The cpu usage is at 36% all the time while the v-ray debugger says: initializing built-in VFB .... and that for 12 hours!!

i need to render 15826x11515 pixels. when im setting this to 14000x10186 ITS WORKING and dont stuck in the "initializing built-in VFB"-message. Why that?

03 March 2012, 05:18 PM
To render large images :
- set your image format in render settings to "vrimg"
- after, set your "memory frame buffer" (always in common tab) to "None"

When your render is finished, use the vrimg2exr tool to convert the result to an OpenEXR file.

If it is not enough :
- use brute force GI (brute GI take less memory)
- try to use my DeeX Vray Fast

03 March 2012, 05:32 PM
THANKS! That solved it... i have tried to set the buffer to none, but it was greyed out hile using exr. with vrimg you can set it to "none". THX a lot... now it starts rendering immediately!!

03 March 2012, 05:58 PM
if that doesn't work, I just added a tiled render command to V-Ray Tuner:

here's a temp download for the script:

I'll update the Creative Crash version shortly.

CGTalk Moderation
03 March 2012, 05:58 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.