View Full Version : Almost a 3dsmax virus - missing dll - MaxLx.dle, infecting files

07 July 2011, 11:17 AM
Hi, so in work we have used some Chinese outsourcing company. Their files were showing "missing MaxLX.dle" error on open. We ignored that, but unfortunately it seems that if you open such file and then you open a "clean" file, it will get infected with the same error.

Now I'm finding my home files infected with the error too. I guess it happened when I did some work at home.

There seem to be an entry in the Track View, in the Medit Materials section, right after the last material that reads ".....Custom Attribute" and this seems to be the problem.

I have found this thread - but it doesn't seem that the problem was solved. I tried a few things on my own but couldn't figure it out.

Using some ideas from that thread, I tried this:

PickedTrack = trackView.pickTrackDlg()
if I pick the weird Custom Attribute track then:
this - PickedTrack.client will return "TrackViewPick:"Missing Custom Attribute Plug-in""
and this - PickedTrack.subNum returns "1"

Unfortunately I'm not sure where to go from here.

I would greatly appreciate any help.

Attached is a simple scene with sphere and the weird Custom Attribute track.
WARNING:behaves like "a virus", if you open the file and then you open any other file, it will get "infected", you need to reset 3dsmax or probably a 3dsmax restart would be better.

07 July 2011, 02:58 PM
Well, picking the material editor node and using

PickedTrack = trackView.pickTrackDlg()
deleteItem PickedTrack.anim.CustAttributes 1

(as suggested in the original thread, too) works for me (max 2011)...

07 July 2011, 03:02 PM
I of course tried that and now again. I'm getting this error:
-- Runtime error: Index is out of range: 1

07 July 2011, 03:06 PM
Are you sure you are picking the "Medit Materials" and not the "Custom Attribute"?

07 July 2011, 03:15 PM
Oh dear, that was exactly the problem. I have NEVER picked "Medit Materials" and was always picking the custom attribute itself. Because the thread I linked in my first post seemed not to solve the guys problem, I automatically thought that the script snippets that were posted there didn't work (but I tried them a few times).
If i would just better look at the script, I could have deduce that i'm picking a wrong track :\

Thanks again.

07 July 2011, 03:19 PM
I of course tried that and now again. I'm getting this error:
-- Runtime error: Index is out of range: 1
what max version do you use?

refs.dependents meditmaterials

does say for you?

07 July 2011, 03:24 PM
Hi Denis, i'm using 64b max2011 and I get this on refs.... -> #($<rootScene>)

Anyway, thanks for the help, but check the post above yours - I was stupid enough to be clicking on the wrong track when picking the track. :\

Sorry for the confusion

07 July 2011, 05:19 AM
see your private messages

CGTalk Moderation
07 July 2011, 05:19 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.