View Full Version : Parented Objects Disappearing in Mental Ray

03 March 2011, 06:29 PM

I am no good at rigging so maybe all you fine people of the interwebs can help out. I'm working with the Norman Rig for Maya. Basically, I'm trying to parent custom hair to the rig. I've parented the hair to both the bone, head controller and both have worked just fine. The only problem is, when I render in mental ray, it's completely non existent. Now, if I unparent the hair from either one, it shows up perfectly fine in the render. If I switch to software render it shows up fine parented or non parented. I did however search the net for answers and all I came up with was one guy who never got his question answered and another who didn't have visibility checked on.

So things I've done:
-Parented to Head Controller (Failed)
-Parented to the Bone of the Head (Failed)
-Switched the hierarchy of the Hair around (Didn't really know what I was doing)
-Tried a Point constraint to the Bone and Head Controller (It wouldn't let me)
-Tried a Parent constraint to the Bone and Head Controller (It wouldn't let me)

Thanks for the future help.

03 March 2011, 10:40 PM
Never mind I got it to work. When I was trying to Parent Constraint the hair to the head I clicked the wrong object first. I had to click the Bone, then the Hair and made sure "Maintain Offset" was checked On and it rendered out fine in Mental Ray. Sweeeet!

CGTalk Moderation
03 March 2011, 10:40 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.