View Full Version : particle bug?

02 February 2011, 08:35 AM

I think this is bug , or i'm doing something wrong.

1.create nurbs plane
2.create particle with emiter
3.make plane goal object
4.add goal u goal v attributes , and create some exp for these
5.create goal world normals pp and tangents pp

With only normals it worked and i thought it is ok , but when i added tangents pp ,scene was bugged , and maya crashed on exit.

I tried again and this time with creation of goal normals pp maya crashed.

Is this bug or...?

02 February 2011, 09:15 AM
please mention your problem with more appropriate details i.e. which maya version you using and so on

i think you should give a try on poly geometry

02 February 2011, 02:17 AM
Here is video demonstrating this problem.

I also tried this:

-making surface emiter
-making creation expression with some values for goalU goalV
-making goal poligonal object
-using nparticles

Nothing above worked.

02 February 2011, 03:04 PM
I would say that (I can't test it right now), if you create 2 new attributs (goal world normals pp and tangents pp) you have to use them, givin them a value. Probably maya is doing a division by 0, or something similar.

my 2 cents

02 February 2011, 05:52 PM
I created tangent pp and give them value and maya crashed again.

Anyway i want to capture result of these attributes , not assign values to them etc.

If this can't work , only way for this is to use mel to get this values like command pointOnSurface which is really slow to compute.

My experience so far with particles is that they are buggy.
Recently i wrote some complicated particle expression which also cause maya to crash.
Basically i don't know what i can/cannot do , i don't know if at end of day particles will let me down or not.

CGTalk Moderation
02 February 2011, 05:52 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.