View Full Version : Maya 2011 weight paint trouble

12 December 2010, 04:25 AM
Hey everyone, im trying my hand at character rigging and ive gotten as far as weight painting.

I understand the concept behind it, found some good tuts on it, but i have a problem now that i cant solve on my own.

Weight painting doesnt work. I had it working on this same file, but something happened. I cant tell you what, or i would have fixed it by now. Anywho, when i click on weight painting, the brush is x-ed out. When i hover over my selected mesh, it is x-ed out.

I physically cannot paint anything, nor can i see the black and white scale display or the multi-colored display that i recently discovered is amazing.

12 December 2010, 08:43 PM
Hi can you please do a step by step description of how your trying to paint weights.?

That way we can tell from your steps what is going wrong also check your sccript editor for any error messages that might have occured.

You can also trying exporting everything and then opening that file and see if this clears it up.

12 December 2010, 11:59 PM
Ok so here is what i do, after opening the file.

I select just the mesh.

Go up to the menu bar and find the 'Skin' menu. Under skin i got to 'Edit Smooth Bind' and then go to 'Paint Smooth Weights Tool' and hit the options box. The tool opens.

Now, i hover the brush over the mesh, and the red circle that is supposed to be the brush with a value in it has an X through it. It basically looks like a cross-hair. I try click on different bones and different parts of the mesh and nothing changes it.

I reset the tool, the values change to defaults and the circle is still crossed.

I check my Shading bar, Smooth Shade All, Wireframe on Shaded, Object Transparency Sorting, and Hardware Texturing are the only boxes checked in there.

Here's the fun part though...

To see if its the file or not, i add in a cube. A regular polygon primitive cube. Then i make a joint for it using the 'Skeleton -> Joint' tool.

I select both and do a smooth bing from 'Skin -> Bind Skin -> Smooth Bind'. No option box.

Then i select just the cube and do 'Skin -> Edit Smooth Skin -> Paint Skin Weights Tool (with option box)'.

I can weight paint the cube fine. It displays it perfectly.

Thats basically it. Im still learning Maya, so anything more advanced then that as far as options go is still beyond me.

Here is what i mean by 'the brush is crossed out'.

12 December 2010, 04:47 PM
Ok first thing you need to do is unbind the skin and delete al that history you have on the mesh. You should have no inputs in the channel box.
I take it you didn't edit the new cube so it was able to paint the weights since it had no history.

12 December 2010, 05:06 PM
Yea, i guess since im a new member here, it takes forever for a post to go through. I solved the problem shortly after posting. I unbound the skin and then just re-skinned the mesh and it worked fine.

So yea, what you said did work, but i found it on my own. Ill have to remember it for the next time this inevitably happens.


12 December 2010, 05:15 PM
Select the skin and under edit delete non-deformer history or you will have more issues.

glad to hear you found a work around. Welcome to the CG world!!

09 September 2011, 09:04 AM
Hey Guys, I know its late but a colleague found a workaround ( it, on the bottom of the page

CGTalk Moderation
09 September 2011, 09:04 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.