View Full Version : Whacky textures on copied objects

10 October 2003, 06:53 PM
Today I played with UV textured objects in Messiah:Studio.
I created the objects in C4D, exported as Wavefront obj, imported them into Lightwave 6.5b and applied the textures again and saved in Lightwave format.
I then loaded the objects into Messiah and rendered - And I liked the result.

Then I saved and reloaded... with this result! House in the background is a copy of the one in the foreground (copied with Clone inside Messiah)

I guess its a error when saving scenes with textured objects?

10 October 2003, 05:24 AM
I played around with it for a bit, and it seems that the UV map assignment in your texture map nodes (the checks next to the UV map name) isn't really set, even though they show up as assigned right after you clone the object. When you reload you have to go back to each of your texture map nodes and check the UV maps to be used for the cloned objects. You can still use one material, but atm you have to tell the app explicitly what UV maps to use.

During subsequent saves and reloading the multi-map assignment will be stored as it should. It'll probably get fixed before the final, but in the mean time this should fix it for you.

10 October 2003, 08:12 AM
BTW, you seem to have the same problem that I had some time ago, a very noisy ground texture. In my case it was the bump texture, that at the default value of 1 is way to high. A normal bump value would be rather 0.1, this should make dissapear the noise. Sorry if this doesn't apply to your scene though...


10 October 2003, 11:59 AM
Thanks for the hints folks!
I promised PmG to send them the file this evening so they can solve the problem.

Maks, I just slapped a texture on the groundmaterial to get rid of this boring blue gound:) But there is a Bumpmap (value 0.25) on it.

The render engine produces good results, but I'm still learing how to get similar results as in C4D.

Btw: any ideas how to produce volumetric lights lights like in this ?
C4D-Render (

10 October 2003, 01:03 PM
To produce volumetric lights you have to activate the fog in render->environment->atmosphere.
It's an overall solution, there isn't a individual option for volumetric lights. But after all, volumetric lights in the real world only occur when there's some atmosphere in the air :)
In addition to that you can activate volume shadows for your light.


10 October 2003, 01:37 PM
And a new option to play with:)

CGTalk Moderation
01 January 2006, 07:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.