View Full Version : DOF in Layout


SubDProxy
10 October 2010, 12:25 AM
Is it possible to activate DOF in Layout. Currently on a project and trying to look at DOF in OpenGL and having no luck. Any ideas?

earwax69
10 October 2010, 12:39 AM
yes, setup your camera dof settings and activate the DOF/MB preview in the dropdown menu at the top left of each preview windows, next to the View menu (front, perspective...) and the shading menu (wireframe, shaded...).

SubDProxy
10 October 2010, 12:52 AM
Thank you for the quick response. I setup DOF in camera settings, turned it on in the drop down menu. Now everything went to wireframe. I tried adjusting it the display options but still the same. Hmmm. Thanks.

earwax69
10 October 2010, 05:18 AM
Strange, it work well for me with any shading mode. I would try to play a bit with the opengl preferences... Or maybe its a bug with your version?

biliousfrog
10 October 2010, 09:11 AM
I'm not sure whether anything changed with recent versions but DOF preview used to be Shift+F9...I do all DOF in post, much faster.

earwax69
10 October 2010, 12:29 AM
I always had bad result especially around edges while doing DOF in post. Its ok sometime but most of the time its not enough for a final product. I use an hybrid of both method, using the camera DOF with around 0.04 or 0.03 of anti-aliasing and I blur it a bit further (to kill the noise) with Dpond DOF node. It give me good result without longer render time.

As both DOF are cumulative, you double the F-stop and voila.

SubDProxy
10 October 2010, 02:03 PM
I need to check out the DPONT DOF Node then. I like his other plugins. Thanks for the advice.

LW-pet
10 October 2010, 03:29 PM
*marginal

http://vimeo.com/14573441

http://www.spinquad.com/forums/showthread.php?29217-Bulbs-%28dof-experiment%29

Cageman
10 October 2010, 09:51 PM
I tried adjusting it the display options but still the same. Hmmm. Thanks.

Make sure your bounding box setting is higher than the number of polygons in the scene.

Preferences -> Bounding Box Threshold

Cageman
10 October 2010, 09:54 PM
I'm not sure whether anything changed with recent versions but DOF preview used to be Shift+F9...I do all DOF in post, much faster.

In recent versions of LW (I think it was v9.2 that introduced this) you can activate DOF/MBlur in the dropdown menu for each viewport.

This allows you to make OGL previews with DOF/MBlur, rather than just doing it on a single frame with the old Shift+F9... and... Shift+F9 only showed DOF, not MBlur.

:)

SubDProxy
10 October 2010, 07:02 PM
Got it working, I appreciate the help. I also tried Digital Confusion with the still images and it seemed the same. I will have to tinker around with it more. Thanks.

CGTalk Moderation
10 October 2010, 07:02 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.


1