View Full Version : Hair & Shadow masking (Hair_tk & Shave)


klazer
08 August 2010, 11:32 PM
Hello, I am working on an independent project which involves a pretty complex character. I've been working with using Puppet's hair_tk shader and Shave & A Haircut just through browsing the forums and reading Puppet's guide.

I need to figure out how to composite the plain character render (SSS, GI, & FG) that includes no hair with a render of just the hair (hair_tk, & p_SpotTK, spot light) and shadowing. I know this can be done somehow with p_MegaTK_passes, but it is beginning to feel a little bit to complicated, and would just like to keep it to two renders if possible. Is there a way to do this with the Use Background or a Surface Shader? I'm still a student and all this stuff is quite unfamiliar to me.

I would greatly appreciate any feedback.

- Kyle

mercuito
08 August 2010, 01:07 AM
I usually turn off primary visibility and gi etc for the hair in the characters pass, that way you get the shadows from the hair falling on the character, then render a pass of the hair, with a blackhole shader on everything else so the hair is cutout correctly

klazer
08 August 2010, 02:41 AM
Where do I find the check boxes for primary visibility & disable GI? I'm not seeing it anywhere in the Attribute Editor when I have the hair selected...

Thanks for the reply
- Kyle

mercuito
08 August 2010, 02:53 AM
On the transform node, under mentalray flags, turn off "Derive From Maya", set visible and globillum off.

Ztix
09 September 2010, 03:53 PM
I usually turn off primary visibility and gi etc for the hair in the characters pass, that way you get the shadows from the hair falling on the character, then render a pass of the hair, with a blackhole shader on everything else so the hair is cutout correctly

I use same the same workflow.
I use maya 2011, SSS, shave 5.5 Hair Primitives, p_HairTK.

I have a problem command line rendering though.

when i have set my rendersettings in maya to raytrace, I can render fine from within maya the GI SSS and hairshadows are all fine, however when i save the scene and reload it the Renderlayer with the hair casting shadows now has the Primary Renderer (in Render settings - Features) Set to Rasterizer (rapid Motion).

Even though i make a layer override and set it back to Raytrace it jumps back to Rasterizer when i reload scene.

This means that when i cmd line render (windows7) it uses Rasterizer on the head which gives some unwantet white noise in the SSS shader.

Is there a way to force Mental Ray to use Raytracer in cmd line i tried Render -h but didnt see any command for it?

Kasper

Is there a way

mercuito
09 September 2010, 07:27 PM
I use same the same workflow.
I use maya 2011, SSS, shave 5.5 Hair Primitives, p_HairTK.

I have a problem command line rendering though.

when i have set my rendersettings in maya to raytrace, I can render fine from within maya the GI SSS and hairshadows are all fine, however when i save the scene and reload it the Renderlayer with the hair casting shadows now has the Primary Renderer (in Render settings - Features) Set to Rasterizer (rapid Motion).

Even though i make a layer override and set it back to Raytrace it jumps back to Rasterizer when i reload scene.

This means that when i cmd line render (windows7) it uses Rasterizer on the head which gives some unwantet white noise in the SSS shader.

Is there a way to force Mental Ray to use Raytracer in cmd line i tried Render -h but didnt see any command for it?

Kasper

Is there a way

This is shave doing it. You can turn it off in the shave globals, its something like, use safe mr settings, or something like that.

Ztix
09 September 2010, 07:51 PM
Thx mercuito that solved it :)

Omarios
09 September 2010, 02:06 PM
thanks for the tips

CGTalk Moderation
09 September 2010, 02:06 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.


1