View Full Version : Importing fur bug?

07 July 2010, 03:06 AM
Hey guys, I've been working on a self portrait, and I've run into trouble using maya fur for eyelashes. I was having issues with final gather washing them out, so I disabled it for a test render. I did a couple of tests, and came to the conclusion that it was necessary for the illumination that I want, but when I tried to turn it back on, it wouldn't work. all the render settings were Identical to the way they were before I turned it off, but I was getting the same bad looking result from my render as I had gotten without it. I played with the settings for like an hour, but nothing could get it even close to the way it had looked before.

in desperation, I reverted to an older save, and tried to import the lashes. I exported the poly base I was growing them from, and the furFeedback object into a separate file, and then imported them into the older version of the scene. when rendering now though, I get terrible artifacts! completely different from what went wrong when I disabled final gather, but just as bad. I tested this scene again without lashes and it looked fine, what could be going wrong?

I'm using maya 2009 mental ray, with final gather and GI. and a bit of AO on the eyes

07 July 2010, 04:47 AM
It looks like you have two meshes on top of each other. Possible?

07 July 2010, 07:22 AM
thanks for the suggestion. I don't think that there were two overlayed meshes, although I agree that it did look that way. I ended up solving the problem by going back to the original file, and importing the version of the face mesh from the previous file, so everything is working fine now. However, I'm also having issues with my normal map from Zbrush. I don't think that all of the detail that I sculpted is coming through, and some areas of the displacement map are actually made worse by the normal map! I can post a comparison between the zbrush mesh and the displacement render if it would be helpful.

Edit: I'm also having issues with the eyelashes casting very big, dark shadows on the eyes, I've tried disabling shadows on the fur preview, and also lowering the the fur shadow density settings. I've also switched off AO on the eyes, nothing doing. I would be happy disabling the shadows completely if i could figure out how. this is a picture of the issues I'm having.

07 July 2010, 06:45 PM
In response to your initial fur question - I generally do not import and export fur descriptions because of their connections to the meshes they were created on. Instead, save a preset of the desired fur and assign it to the new model as a new fur description, and then re-add any attribute maps you were using.

07 July 2010, 10:41 PM
Thanks a lot, that will be very helpful! one question though, on a mac, where are the maps stored? Also, clumping doesn't seem to work correctly with the inclination and curl values I've applied. it moves the hairs up and down much more than it moves them closer to each other, any fix for this?

07 July 2010, 03:37 PM
The attribute maps, once baked out, will be in your current Project directory. Inside a folder called furAttrMap.
Yes, this clumping issue is one I've run into a lot and seems to be a limitation of what is possible with Maya fur. The clumping works by either pulling the roots together to form a concave shape, or by pulling the tips together to form a more convex shape (controlled by clump shape). If you have curl pulling the tips and roots in a different directions the pull of the clumping becomes a lot less apparent. Try lowering the curl again, get the desired clump shape first, then bringing the curl back up to get the desired look. Or try scraggle instead of curl(?). It'll take some tinkering around to get the look you want.:wip:

07 July 2010, 08:29 PM
Thanks for the advice, I was afraid of that. The issue that's rankling me most now is the one about my normal Map, which I have been completely unable to resolve. Whats weird is that they look great in the viewport, with advanced shading turned on, but as soon as I render, most of the detail is lost. I've found other people with this problem, but never any satisfactory answers. most people seem not to have this issue at all. I've tried switching between object and tangent space with my maps, and turning adaptive on and off, but I feel like the problem is with the way I'm rendering them in maya. I'm ready to tear my hair out over this, any help would be greatly appreciated.

08 August 2010, 11:36 PM
I figured it out! I used UV Master for the UV's on my model, and the face had gotten squished by the automatic mapping. I redid them and now the detail comes through perfectly.

CGTalk Moderation
08 August 2010, 11:36 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.