View Full Version : Maya 2011 not flushing memory after render?

07 July 2010, 05:03 PM
Is anybody else having this problem?
I'm opening a pro-e model (nurbs surfaces, not especially complex) and rendering in mental ray.
The file is 466mb in my task manager to start with.
I do a rendering and the memory goes up whilst calculating, finishes, and the memory usage stays up at 640mb.
After a few renderings (with the memory usage slowly creeping up each time) my computer tells me to allocate more virtual memory and shortly after MentalRay stops working.
I then have to save and restart Maya

Its Maya 2011 with the latest service pack. I've got 4GB memory.


07 July 2010, 04:00 AM
A memory leak like that is usually a bug. Log it with autodesk and send them the scene file.

07 July 2010, 04:48 AM
I guess its even happening with the 2010 version...
at times even after the render image is generated it takes a lot of time for the software to "finish" the renders. I felt this issue while rendering with mentalray batch render. Currently I am just killing mayabatch through the task manager lol.
Does anyone have the same issues....

07 July 2010, 04:24 AM
Maya 2011 has a parameter called allocate on heap which is in options tab performance,
turn it on and mentalray may take time to render the image but it may prevent maya from stopping unexpectedly due to a stack overflow.

07 July 2010, 08:26 AM
Out of curiosity, do you have a machine with hyperthreading?
I had a memory leak due to that.

07 July 2010, 08:49 AM
If this is the same kind of leak that 2008 has (I haven't used anything higher than 2009) then this just might work.

If you want to flush the memory usage, minimize Maya by clicking on its icon on the task bar (not by hitting "minimize," alt-tabbing, or selecting another window from the task bar). I've had mine go from 1 GB usage down to 20 MB. Strangely enough, this also worked when I tried it on Vegas and Photoshop, so the OS might be partly to blame as well. I have no idea why this works, but it does for me.

07 July 2010, 11:16 AM
thegreybox -that's genius. Really didn't expect that to work. Very odd.

Yann1ck -yes it is a hyperthreaded machine

caveman -cheers. noticed that heap thing on MayaStation. I'll try that sometime.

mduvekot -I'll log it when I have a quiet moment.

My suspicion is that it has something to do with my basic scene that I import stuff into which was created in Maya2010. I had similar issues going from 2009 to 2010 aswell.

07 July 2010, 11:57 AM
There is bug with hyperthreading that create a memory leak.
It usually give you this error message:
"Error: Exception occurred during the execution of node callback 'TpolyBasket::completeMeshCallback'. Node callback mode: 5."

I had to downgrade form Maya 2010 to Maya 2009. It seems that 2011 doesn't have the problem (so far).

07 July 2010, 07:42 PM
I had to downgrade form Maya 2010 to Maya 2009. It seems that 2011 doesn't have the problem (so far).

That would be called "an upgrade", around these parts! (grins) Maya 2009 is thus far the most stable of them all, although it still has its quirks of course...

CGTalk Moderation
07 July 2010, 07:42 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.