View Full Version : zdepth giving me anti-aliased images

07 July 2010, 01:43 AM
I am rendering out my z-depth pass at double resolution but I seem to get anti aliasing along the edges. The only place they are aliased edges is along the alpha edge, everywhere else there are gradients. Is this standard? I've heard you want a completely non anti-aliased image?

07 July 2010, 03:23 AM
What are your render setting at?

07 July 2010, 03:55 AM
I'm using mental ray "Production" settings.

07 July 2010, 03:56 AM
I get very nice and clean results around the alpha edges in post with depth of field when I render my z-depth passes with Premultiply turned off (for mentalRay, you can find the option under Quality -> Framebuffer).

07 July 2010, 05:01 AM
what you are basically wanting to do is turn off the oversampling. so it is AA 0 0 and turn off the Framebuffer -> interpolate samples

and keep in mind to render z depth with at least 16bit (better 32bit floating point of course)

07 July 2010, 08:25 PM
Looks like checking off "Interpolate samples" in framebuffer was the main issue. Thanks for the tip. I am trying to render out 16 or 32 bit depth maps but I can only seem to get 8. I'm rendering targa's and opening them in fcheck and re-exporting them as targa's so I can read them in after effects. Any idea how to get more than 8 bits?

07 July 2010, 08:53 PM
I would always render 32bit floating point in EXR. Imho its the best file format.
Targa cant store more than 8bit per Channel.

07 July 2010, 10:48 PM
Unfortunately EXR isn't supported in AE. I am able to render uncompressed tiffs at 32 bits but the depth can't be read in photoshop or AE unless I re-export it using fcheck which produces 8 bit tiffs. Pretty annoying... I'm sure there is some way to get working 32 bit depth passes though.

CGTalk Moderation
07 July 2010, 10:48 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.