View Full Version : how can I access z depth

07 July 2010, 01:47 AM
I am renderring a tif sequence in maya with depth turned on. I see, when I use photoshop to look at the target directory that there are corresponding depth files. But they are grayed out and I cannot access them. How can I get to the so that I can use them?

07 July 2010, 04:56 AM
From memory, it outputs depth as 32bit iffs, which photoshop can't read. If your using 2010 (im not at work, so i cant check this), check out the buffers section in the render globals, and you should be able to output "normalized depth", and be able to select a format that photoshop can read (like tiff).

08 August 2010, 07:16 PM
Sorry to have dropped this thread... SIGGRAPH killed me.

But I am back now. Well I went into render globals>Quality>framebuffer: There, I set the Datatype from RGBA [Byte] 4 X 8 Bit
To Depth [Flota] 1 X 32 bit. The resulting tiff was simply a flat of purple. with (obvioulsy) no alpha channel. So clearly I am not getting what I want. All I want is to render out a simple grayscale map with which I can control depth on the render in maya. I really thought this was easily accomplished.

Clearly not. I rendered out depth passes using the render passes I get flat black and white images which gives no depth cues! Do I need a shallower depth of feild on my camera? I wish I was getting results... then I would be able to show something

Any help would be appreciated.


08 August 2010, 11:44 PM
fcheck is a default maya utility which can open and save .iff files into other formats

If you are using render passes together with photoshop, you will want to make sure the pass is rendered out as 4x32 bit float, or 4x16.

Then change the exposure in photoshop to get the grey scale values you want.

Floating point means the pixel values are above 1, and can reach into the hundreds....which is why the images will be displayed as all white. In fact, the value will actually be equal to the distance in maya units.

08 August 2010, 12:13 AM
Mason, quick question Are you saying I should switch the frame buffer to depth, set it to 4 X 32 (doesn't seem to be a possible option) and then render out and then use fcheck to resave as an understandable format? Not sure where the fcheck comment came from...

I just want to get usefull render data...


08 August 2010, 04:32 AM
Are you using photoshop to composite your sequence ?
I would suggest you to try out these amazing compositing softwares like Nuke
Just render a multichannel exr with the depth as a buffer in it,
In nuke seperate out the depth buffer using shuffle..
and apply a grade node to it and play around with the gain and multiply values and you will get your right depth.. thats as easy as it is in Nuke

08 August 2010, 04:51 AM
Wow. Thanks Caveman. Yeah I need to learn Nuke for (literally) a myriad of reasons. Seriously. A myriad. I have exactly 10,000 reasons for learning nuke...

I did get to do an exr and it did work. But not when I was using render layers...

When you say I need to add depth as a buffer exactly where do I do that in maya? Is that in the framebuffers in the render globals?


08 August 2010, 04:56 AM
are you sure your using normalized depth?

08 August 2010, 04:59 AM
Uh... no. I am not. I should have said. I am using MAYA 2009. I am not sure where the setting is for normalized depth. I mean I think I get what that means, it takes the given distance from camera to clipping plane and normalizes it, setting the depth values from 0-1 then applies the gray scale accordingly right? Still though not sure where the settings are.

08 August 2010, 05:33 AM
If you are using Maya 2009 and later version you can add depth using the passes tab..

I'll guide you through the process.
1: Select the render layer from which you want to derive the depth pass
2: Open your render globals
3: Select Mental ray as the renderer ( I hope you are rendering in mentalray)
4: There will be a second tab called Passes, click on that
5: Click the first button next to the Scene Passes window ( When you will drag you mouse on the button it will give an annotation as Create new render pass)
6: After you have clicked on the button a popup window will open up
7: In that select either Camera Depth or Camera Depth Remapped
8: Dont forget to give it a pass prefix as eg Test_
9: Click on create and close
10: It will create these passes in the Scene Passes window
11: Now you need to associate this with your selected render window
12:With these passes selected click on the Down arrow which is below the Scene Passes window
13: You will see these passes in Associated Passes window (Now you have associated these passes to the current selected render layer)
14: Render the image and you will get your depth as a frame buffer output..


08 August 2010, 06:09 AM
Ha! I had always been doing just that. The depth tif that got rendered is pure black and white.

I then took it into after effects and by adjusting the levels I did in fact pull a gray scale image out of it. But the resulting gray scale is very poor the gradients are very, very stepped. I was hoping for a much more gradual image. Is there a way to get maya to render this better?

At present it looks like this:

08 August 2010, 06:57 AM
is your AE project settings set to 16 or 32 bits per channel or the default 8 bits per channel?

08 August 2010, 08:26 PM
Really? AE needs to be told to access it as a 32 bit image? I thought it just recognized the settings and went with that...

08 August 2010, 08:37 PM
Ok, I went into the project settings and set the color settings>Depth to 32 Bits per channel (float)
I even played around a bit with the working space I still get a terrible render. Just like the one above.

08 August 2010, 02:19 AM
I don't know, you sure you rendered it as a 16 bit RGBA short/half or a 32 bit float in the frame buffer settings?

08 August 2010, 04:41 AM
Positive I set the framebuffer to 32 bit float RGBA and I output as a tif.

08 August 2010, 04:47 AM
Can u upload the rendered image so that we can check it ?

CGTalk Moderation
08 August 2010, 04:47 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.