View Full Version : lm2DMV - Missing Max Displacement

06 June 2010, 03:43 AM
Okay, so. I use Maya 2010 x64 and have been very interested in the 2d vector shader, lm2DMV for a long time.

I was able to install and use it successfully. The shader itself is great however, the max displacement feature that I read about (which should be in maya's output window) is missing. I've used the shader for simple scenes but I loathe not being able to key frame the normalize attribute in a time efficient manner for complicated motion in my renders.

As far as installation goes, I:
(Disclaimer: I tried to find a x64 version for the shader but the only one that I found mentioned on the site was for XSI...)

downloaded the Maya reference files off the website
- put the .dll file in the mentalray/lib folder
- put the .mi file in the mentalray/include folder
- put the .xpm file in the icon folder
- ran and sourced the AElm2DMV_v2.mel in the scripts/startup folder
- changed the end of the mental ray maya.rayrc file to appear as follows:

# link "{MAYABASE}/lib/lm2DMV_v2.{DSO}"
# mi "{MAYABASE}/include/lm2DMV_v2.mi"

# end registry

I even have my translation verbosity to detailed messages using the following MEL command:

setAttr mentalrayGlobals.exportVerbosity (6);

I BELIEVE I used the adequate render settings (more on that if you want those details) and the image came out just fine but in my output window, I couldn't find a message that told me my max displacement.

Does anyone know what's going wrong here?


06 June 2010, 10:17 AM
render>render current frame options (set verbosity to 3 or 4, can't remember -- progress messages?) it will show in the output window, but might not be the last message, so you have to scroll.

as far as I can remember it won't show in the script editor. To be honest, if you render to 16bit/32bit, set the max displace high enough and you won't really have to worry about 'clamping' your values.

Oh, and I'm pretty sure you shouldn't keyframe the normalize option, because it will affect the way the moblur renders in post (ie for a same distance moved your moblur will change because normalization will change the 'mapping' of the pixel from color -> distance)

06 June 2010, 11:50 PM
Ah! It worked! I got the message woohoo~. Thank you so much! You mentioned that that MEL command only changed what is shown in the script editor and noticed, as I changed the different settings, my outliner stayed the same. I followed what you had said and now I get it in my output window ^_^. It's not giving me that weird glitch where it says max displacement --> 0 pixels and everything is working fine.

Thank you so much!

CGTalk Moderation
06 June 2010, 11:50 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.