View Full Version : zBrush tools suddenly read only as Unix Executable Files on Mac OS X.

05 May 2010, 07:41 PM
I am taking a creature design class at my school and I'm currently sculpting it in zBrush. The computers at school run Windows 7 and zBrush 3.5R, while at home I have a MacBook Pro with Snow Leopard and zBrush 3.12.

Today I took the zTool to school and worked on it a bit in class, and when I came home all the ZTL's and ZBR's on my thumb drive suddenly show up as "Unix Executable File" in Finder instead of Documents as they usually do. When I try to open the tools in zBrush I just get an error message saying "Error has been encountered while trying to load a Tool. Loading has been aborted."

This is the first time I've brought my Tool to the school computers. II figured it might be the transition to Windows or a later version that causes it, but all of the zbrush files on my thumb drive have become Unix Executables even though I only opened one of them.

What is going on?

On this image you can see the Thumb drive at the bottom and on the top is my work folder with the bug3.ztl copied from the flash drive. Notice that it's the only one that shows up as an Unix Executable.
05 May 2010, 07:47 PM
Try with repair permissions with Disk utility!


05 May 2010, 11:47 PM
Thanks for the suggestion! I tried that but it sadly didn't work. :(

But I did some research and came upon this thread at

It seems like Windows and OS X have different ways of labeling and handling extensions and executable code, so it seems that windows must have overwritten some lables or permissions in my .ztl files when it accessed them.
Response number 9 in that thread suggested to use the terminal command chmod -x * to purge the unix executable association on all the files in the selected folder. I put my .ztl in an isolated folder and ran the command, and it worked! The file is no longer an Unix Executable. It didn't really solve my problem though as I still get the "Error has been encountered while trying to load a Tool. Loading has been aborted." when I try to load it in zBrush...

Now what?

Could it be a version incompatability issue? As I said I'm running 3.12 here at home, and the school has 3.5r.

05 May 2010, 12:23 AM
Another update.

I decided to do a little experiment to see if it's really the different versions of zBrush that screwed me over.

I found one of the earlier versions of the tool that I hadn't opened in zBrush at school but that had been a victim to the Unix Executable File bug. I ran the chmod -x * command on it and turned it back into a normal document.

I was able to open it in zBrush. In fact, I am able to open the version that still reads as an Unix Executable File, I have no idea why I didn't try that earlier...

So it seems obvious that the Unix Executable File tag wasn't the problem in the first place, and that the reason I can't open my tool is because I worked on it in a newer version of zBrush.


Is there a way of opening tools from a newer version of zBrush in an older version?

05 May 2010, 01:34 AM
To exchange files between different versions of ZBrush, you need to export to the GoZ format. I just tried it between two versions and it works and contains the subd level.

if you need to change the owner of a file or all for a file type, get info on it in the Finder and change the Open with application:

also, make sure that you have the latest version for OS X - it's 3.2

CGTalk Moderation
05 May 2010, 01:34 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.