View Full Version : Symmetry!!! Arggh!!!

04 April 2010, 09:45 AM
Hello there peeps... ive been modelling this super soldier for a while now... the premise is that he's a cyborg...(typical).. he has a mechanical right arm and wires and stuff coming from him... but I have this issue... I started off with a box mesh I created in maya.. and obj'd it into zbrush to begin sculpting... no problems... the issue arises when I import all other details, such as the arm, the visor, his armour. They import into zbrush at a really small scale compared to the model. Where as when they were modelled in maya, they were modelled to scale to a draft copy of the model.... so the sizes should match i've been scratching my head as to what the problem is?? I then thought to import the appendages using subtool master when i import the original box mesh of the character.. it worked no problem.. but when i came to creating a few mre aspects of his mechanics in Maya, and then import them into zbrush...again, they were ridiculously smaller... It seems to happen if I hide select a certain area... say the head for instance to work on... it seems to completely mess up the symmetry...I've tried to set the pivot point....clear the pivot point... ive tried unifying the geometry... to no avail... all i do know is that in the preview window... the model of the soldier is huge... but can't seem to get it to reset.... has anybody any ideas??? Please help as im sick of banging my head against the monitor.... plus I have to write a dissertation on this bad by as well......all advice woould be gratefully recieved... cheers!! :(

04 April 2010, 05:38 PM
wow, that sounds extremely frustrating and annoying, but I can't think of too many reasons why that could be happening...

One of the things I can think of is group transforms.
If all of your objects inside your 3d app are in a group that has been scaled down or up,
when you export the individual object out of the 3d app without un-grouping it and freezing it's transforms first, it might cause that object to scale back to it's original size before its parent group node was scaled down or up...
Does that make sense?

Sry if this doesn't help any... you really do have a conundrum here :sad:

04 April 2010, 08:45 PM
I just want to subscribe to this thread in case someone answers it cause I've been having the same problem only with things coming in huge despite them being to scale and often from the same maya file. Only thing I know to work (which isn't helpful unless you import all at once) is to combine them all into one piece of geometry then you can create polygroups from contained geometry (or something like that, can't check at the moment) then create subtools from polygroups. Anyway, good luck, hope someone can answer this cause the seemingly random scale import thing in zbrush drives me nuts.

04 April 2010, 03:09 PM
I haven't had this problem but then I don't import many subtools.
One thing you might try is freezing transformations on each mesh before exporting the .obj

04 April 2010, 03:57 PM
yeah, the first thing i would try is to, in maya, delete the object histories, and freeze and reset transformations. Then re-import into zbrush and see if it fixed your problems..

04 April 2010, 12:16 AM
The scale problem has a couple of solutions over at zbcentral trouble shooting forum. Just enter scale in the search on that forum. The workarounds are too wordy for me here but I noticed opening your tools with the simple brush active instead of the sphere seems to help.

CGTalk Moderation
04 April 2010, 12:16 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.