View Full Version : nCloth Problems -urgent-

03 March 2010, 03:59 PM
Hello there,

I've been working on a short animation for class recently and I have come to the stage where I need to create clothing for my main character. I've used nCloth in the past successfully and feel I have at least a basic understanding of how it works. For the past 24 hours I have been attempting to get this vest to rest on this body by simply selecting the vest mesh and creating ncloth, then selecting his body and making it a passive collider. I then try to run the simulation from frame one... but nothing happens. The time slider just plays through and nothing in the view port moves. If I try to select the vest mesh in object mode and attempt to move it, only the manipulator will move, the mesh remains in place until I delete the history. After that point if I try to run the simulation again I end up going through the same process. I have deleted my preference, tried this on new and/or different files (every time it is the same thing), and even reinstalled maya twice now (once just the program and once both the program and documentation). After reinstalling the second time, it worked twice, then the same problem kicked back in.

I REALLY need some help on this and truly appreciate all anyone can offer me.

For informational purposes I am running Maya 2009 Unlimited on a q6600 quad core, 4gb ddr2, gts8800 graphics card.

Thanks in advance,

03 March 2010, 08:21 PM
Sounds like a pretty odd situation. I have seen nCloth do something like that in the past. But not consistent enough to report as a bug. Restarting Maya or remaking the nCloth node. Was enough to fix it.

I would try exporting your mesh to obj and reimporting. This may clean out any bad geometry nCloth is having trouble with.

03 March 2010, 03:15 AM
have you tried remaking the cloth?
are you making the cloth with "world" or local" space output? (always use world)
do you have a cache?
have you added some history to the mesh?


03 March 2010, 03:25 PM
I have run into this as well on occasion. I will have ncloth in the scene and then try to create and ncloth surface and it is just dead. Usually starting a new scene fixes the problem, but sounds like you are not having much luck. A couple of other things to always check is to which solver your ncloth is attached to. If you have multiple ncloth objects or you are starting inside of a scene that had ncloth at one point, you might have numerous existing solver, perhaps the solver is disabled?

03 March 2010, 04:52 PM
this happens ALLLL the time... ncloth just doesnt work... even after using the same Maya for days, load a scene and randomly ncloth just doesnt work...

always restart maya and it comes back....

sounds like youve got something worse though...

03 March 2010, 06:12 PM
possible reasons:
24/25 frames a sec issue. Be sure you have start of playblast/simulation on same keyframe, and that number is nice round exact number as it should be.
Project is not set on the right directory. 2009 made a mess out of this. You might have an issue if you are using old project/setting.
Scale. If the scale of the scene is wrong.
Maybe you've set some parameter by accident to zero.
Check the thickness of the cloth, visualise it. If it has nowhere to go, it might get stuck, and go nowhere.
Check precision of simulation.
Is it self coliding?
I can't think of anything else at the moment...


CGTalk Moderation
03 March 2010, 06:12 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.