View Full Version : nCloth Render issue

03 March 2010, 08:44 AM
Hello all
I'm working in Maya 2010 doing my graduate thesis and I have a fairly long scene (around 7000 frames). I have several ncloth objects in the scene and have cached them all out, and everything works just fine. However when I try to batch render a section of this scene (say frame 5000 to 5100) with Mental ray Maya works for a minute or two and then the render finishes without creating any image files. If I try with Maya software it starts rendering and never gets anywhere. If on the other hand if I start rendering from the beginning of the scene with Mental ray it plows along just fine.

I am wondering if this is due to the Cached ncloth simulation and if I should bake out the simulation and that would solve my problem, or if it might be something else entirely. At the moment I'm stumped.

Has anyone else experieced something similar?


P.S. I tried to upload a zip of the file but it was too large.

03 March 2010, 06:44 PM
yah I would try baking the sim into a geometry cache then disableing the nucleus and ncloth solvers.

03 March 2010, 07:59 PM
I does sound like you are getting runups, which can still happen in some cached situations. The solver may need a runup to have correct values for running off the end of the cache... the runup will not solve for everything, but things like constraint link creation and object bounds will still get evaluated and can be slow. However if you disable the cloth solvers (nucleus nodes) it should avoid the runup... no need to create geo caches. It might also be safe to disable any constraint nodes as well, although disabling the nucleus nodes should be all that is required.


03 March 2010, 10:30 PM
Hello Duncan

Thank you for responding to my post.
I have two nucleus solvers in my scene and I tried turning off both of them as well as all the dynamic Constraints like you suggested, but that did not seem to change anything. Most of my cloth objects are in the scene from start to finish (they are using one nucleus) and so I cached them from the begining. I have another ncloth object which comes in toward the end of my scene and I only cached it for the number of frames it would be on camera. It has a separate nucleus all to itself which is set to start evaluating when it comes on camera (around frame 5000). I am wondering if I should cache that cloth object from the beginning of the scene as well. Could that be causing this run up issue?

Thank you again for you time

03 March 2010, 02:37 AM
Since my last post I decided to try and baked the animation using Edit>Keys>BakeSimulation (with control points turned on) to see if that would fix the rendering problem. The result is my file size is huge (approaching 500 MB) but provided I have enough RAM the scene seems to render fine.


03 March 2010, 02:53 AM
Instead of baking you could use a geometry cache, which would not create the memory problem.

Your cloth with the limited cache may be the cause of the runup problem, although I would have hoped that disabling all your nucleus nodes would have fixed things. It might be helpful if you could submit a simplified bugfile from your scene.


03 March 2010, 03:30 AM
I'm afraid I couldn't get the file size down below 2 MB limit without deleting something that would change the simulation, But thank you for the suggestion about the geometry cache. I'm going to look into that.

Thanks again

CGTalk Moderation
03 March 2010, 03:30 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.