View Full Version : Maya Paints No Weights

03 March 2010, 03:03 AM
As the title says, the Maya won't paint weights when I enter the smooth bind weight paint tool...

Frankly speaking, it won't paint at ALL (neither textures, bumps etc) but right now, is the weightings that worry's me the most...

So that's why I really need some help on that...

Well, after some tries, I accidentally got it going (dunno how...) but a few seconds later, the program crashed... Since then I never got it going again!

In both versions of Maya that I have (2009-2010), It happens the same thing...
The only thing that I can guess is a bug with the graphic card, but I'm not quite sure...

Technical information that you might want to know:

Mac OSX Snow Leopard
Nvidia GeForce 8800 GT

If you need to know more than that, feel free to ask!

So, every suggestion is welcome!
Thank you for your time...

03 March 2010, 02:45 PM
first things first. If your having trouble with maya just starting up. First try and deleting the MAYA.env file. This is the maya enviormental file, it sometimes gets corrupted and needs to be rebuilt by maya even if there is no information in it. Just delete it. Don't worry Maya will rebuild it automatically when it starts up.

secondly when your painting weights there are some things to be sure of.
Paint weights only works in Object mode.
Make sure you have a skin clsuter and that you are smooth bound and not rigid bound. This also only works on Sub-Ds and Polys not on NURBs.

In component mode you can select a particular Vertex or a group of vertices and look at their wieghts specifically with the Component Editor.

Without seeing a scene file or a screen shot of the mesh with the mesh selected and the channel box, most all we can do is guess at what might or might not be going on.

03 March 2010, 10:30 PM
I deleted the "Maya.env" but it didn't work...
It seems it's not the preset files that blocks the paint tool...

Yes, the model is made only with polygons, and before I rig the mess on the skeleton I deleted the history, there are no other nodes evaluated between the mesh and the joins.

Let me tell you a detail, I totally forgot...
I brought my scene to my class to ask the teacher what's the problem.
But, in the computers of my class, the paint tools were working fine!

So in other words, the problem is not in the scene, but on my computer...
I double-checked the preferences if I could find anything out of the ordinary, but it seemed good to me...

03 March 2010, 12:07 AM
Well, I'll have to go for the "Rigid Bind" and I'll adjust some Flexors...
They actually work even better than the "Smooth Bind" if you adjust them just right...

But I will be checking this post in case a solution come up...

Thanks in advance... =]

03 March 2010, 02:49 PM
Without seeing a file or a screen shot of the mesh and its channelbox and or outliner its jsut going to be guess work to offer you a solution or a suggestion as to what may be causing the issue.

03 March 2010, 12:33 AM
Here is a sample, the hand.
The rest of the scene is made quite the same way, same analogy polygons-joints.
Most probably you are not going to have a problem painting weights in your computer, as I said the problem is not in the scene...

03 March 2010, 12:31 PM
Taking a look at the rig now. Some Intital notes. (opions may vary)
One of the places where you are more than likely having the issue is from the Referencing. If you have controls inside the Skeleton and you hide the controls that are refenced it hides all the transform nodes on your mesh. Its a complete pain in the butt.

The Namespace is more than likely the culprit in your problem with wieght painting.
Don't use namespaces if you don't have to. Use prefixes and underscores. It's cleaner and more effiecent.

for a student starting out you have 10 times too many polys in that hand. At the moment you have 1469 verts in the hand or 1448 Quads/2896 Tris. This hand should be around oh... 146 quads(give or take a few polys for finesse). Using your normals to round the edges.

Referencing is fine but reference the Bound model into the rig. Not the mesh into the rig. This will save you time and trouble.

Controllers should be outside of the Skeleton to prevent GImbal locked controllers.

DONT use orient constraint. Use Parent Constraint (Rotate Only) the reason is that you don't want to modify the Orientation of the axis (which is what Orient Constraint does) while Parent Constraint Rotate keeps your orientation axis and modifies the rotation, hence you get a clean X to Y rotation transform. If you need it, which you do sometimes.

Also having your controls outside of the skeleton will allow you to freeze transforms and clean up your controls. All you controls should be at 0,0,0 for Rotation and Translate. Becuase if you don't your animator will, and your animator will break your rig in nothing flat. and you'll have to do it all over again. Don't waste time.

03 March 2010, 03:16 PM
Thanks for the advice mate.
But did your paint weight tool worked on it?

03 March 2010, 06:33 PM
Yes the paint weights worked just fine in Maya 8.5

03 March 2010, 02:02 AM
Well, it seems clearly to me that it's an OpenCL bug...
I can't fix that... I don't even know if it is fixable...

Anyway, thanks for your time mate, I appreciate that!

I'll keep on checking on that post...

CGTalk Moderation
03 March 2010, 02:02 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.