View Full Version : how to fill hole from missing face?

03 March 2010, 01:41 AM
Anyone know how to fill a hole in a mesh in Zbrush? It would seem I somehow deleted a face. How do i get it back? Is there a work around? In Maya I waould use the append to polygon tool. How ever going back to maya isn't an option.

03 March 2010, 03:10 AM
Retopologise the mesh in zbrush or another app.


03 March 2010, 03:33 PM
Why is going back to Maya not an option? If you are using 3.5r3 you can use the GoZ functionality built in to import a mesh with a new vert order and still have all of your high resolution details intact.

Save out your Zbrush sculpt at it's lowest level as an obj.
Import it into Maya and fix your mesh then save it out as a new obj.
Back in Zbrush, with your tool still active import your fixed mesh.
A dialogue will pop up asking if you would like to project details, say "YES".

Zbrush should be able to project all of your high resolution detail and polypaint from your sculpt onto the new mesh.

One thing I just learnt the other day is a small glitch with the projection settings in Zbrush. Your blur settings (default 10) needs to be set to a power of 8. So 8, 16.... If you leave it at 10, you can get some artifacts in your projection.

After all of this, if you don't want to do it this method. Zbrush now has a close holes tool in the geometry pallette. Although you cannot have multiple subdivision levels to use this tool.

If you are on a mac, just use GoZ for maya to do the same as above. The only difference is there is a button with the mac version.

Hope that helps.

03 March 2010, 05:40 PM
thanks guys, i will do what you have suggested.

03 March 2010, 06:18 PM
I don't know why but Zbrush seems to be refusing to output a useable .Obj. I import the .obj in Maya and it is an infinitely small point that has the correct number of faces. If I try to import the .obj into Zbrush it error's out. If I use GoZ I get an error. If I export as a .ma it errors out when I try to open it. I really dont know what the problem is. Seem the vertex order is broken? I tried retopologizing the tool but it error's out because it has tri's. I dont get it.

figured it out, the scale factor was set to nan, i set it to 1 and then exported it fine.

03 March 2010, 07:01 PM
what is it with nothing ever working like it is supposed to in CG? So my GoZ button in Maya gives an error saying invalid -nn in the script editor. I export as an OBJ out of Maya and import it in Zbrush like you said, and when i reproject my high resolution detail everything turns black. I try to re-draw the tool and nothing.

03 March 2010, 07:42 PM
Sorry, are you on a mac or pc?

03 March 2010, 08:48 PM
Im on a MAcpro 2.8.
I made a sphere in Zbrush, sculpted it with a 3 levels of division. Exported the lowest division as a OBJ. Then imported it and hit yes when asked if I wanted to transfer the high poly sculpt, and it worked. So the problem must be with my model. I just don' :banghead: t know what the problem is.
I'm not incredibly far into the sculpting so I may just redo my work.

03 March 2010, 09:05 PM
So, if you are on a mac, I'm assuming you are using Zbrush 3.2. So you should be able to just install goZ for mac:

You can forget all the import/export stuff I just said. use goZ to send your tool to Maya. I'd use maya's geometry check tool to see if you can figure out what's wrong with your model. Also fill in your holes and send it back to Zbrush using goZ.

Hope that helps.

03 March 2010, 02:05 AM
i do have GoZ installed. It is completely broken. I have a ticket open with pixologic support for help. In my previous post I outlined that problem.

03 March 2010, 02:53 AM
found this video

CGTalk Moderation
03 March 2010, 02:53 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.